Showing results for 
Search instead for 
Did you mean: 

cannot place Cases

New here

cannot place Cases

on dashboard, every time I create a case, 


It shows an alert "INVALID CAPCHA" and the case never gets submitted 


has anyone have the same issue? 

Kind of a big deal

Re: cannot place Cases

I have never been asked to fill out a captcha when logging a case. Possibly its a new feature they are implementing and haven't got it quite right yet. I have been able to update an open case of mine without any issues


Are you able to call support for the time being, may also pay to let them know.



Meraki CMNO, Ruckus WISE, Sonicwall CSSA, Allied Telesis CASE & CAI
New here

Re: cannot place Cases

here it is the error:






Once placed submit... it remains that way ... but the case never submits 




Head in the Cloud

Re: cannot place Cases

This might be a UI bug. I'd recommend just giving support a call (help>get help) for your best support number and asking support.


I've had no issues submitting cases.

Eliot F | Simplifying IT with Cloud Solutions
Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Building a reputation

Re: cannot place Cases

As luck would have it, I ran into this exact issue this morning submitting a case.


I received the same error about the CAPTCHA.  In my case though, the 'I'm not a robot' box appeared below the case description field and I was able to check the box.


It appears that Meraki is using Google's reCAPTCHA in an invisible mode.  I'm guessing that if you don't 'pass' the check when you submit the case, the checkbox is supposed to appear, so that you can assert your non-robot-ness.

Kind of a big deal

Re: cannot place Cases

It looks like they "fixed" it so at least the CAPTCHA box appears after the failure alert. Better than nothing.