Wi-Fi Disconnects after Sleep

New here

Wi-Fi Disconnects after Sleep



Recently, I have had Windows 10 and Windows 11 clients keep disconnecting after opening there laptop. This usually happens after they have roamed to another location either within the building or to another building. I have many AP's around campus. I have been trying to work with Meraki support and adjust the RF settings with the min. bitrate and radio settings. I thought this helped and I think it has a little but something is still going on.


One thing I have noticed that clients that do not have sleep on after closing the laptop seem to keep the connection after roaming. 


Does anyone have any suggestions for me to try have the Wi-Fi automatically connect after roaming?

Kind of a big deal
Kind of a big deal

@Devi many users have reported issue with Intel wifi adaptors and Meraki. I'd suggest doing a quick search and seeing if the problem you are having is the same as others have had in the past. 





Thank you for the suggestion! I will try searching for these types of threads instead. So far I have only found other Wi-Fi related threads and most suggest RF adjustments.

What type of encryption are you using, PSK, 802.1x or something else?

I am using PSK. Meraki suggested that we disable 802.11r because clients started dropping connection in the middle of them working on the laptops.


I would check for driver updates, are the devices set to connect to the SSID automatically?

Kind of a big deal
Kind of a big deal

Legacy clients cannot associate with a WLAN that has 802.11r enabled if the driver of the supplicant that is responsible for parsing the Robust Security Network Information Exchange (RSN IE) is old and not aware of the additional AKM suites in the IE. Due to this limitation, clients cannot send association requests to WLANs. These clients, however, can still associate with non-802.11r WLANs. Clients that are 802.11r capable can associate as 802.11i clients on WLANs that have both 802.11i and 802.11r Authentication Key Management Suites enabled. The workaround is to enable or upgrade the driver of the legacy clients to work with the new 802.11r AKMs, after which the legacy clients can successfully associate with 802.11r enabled WLANs. Another workaround is to have two SSIDs with the same name but with different security settings (FT and non-FT).

@BlakeRichardsonand @alemabrahao Thank you both for the help! I will try the driver update. I will look into testing out setting with a second SSID as well.


Thank you for the suggestions!

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Community News