cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SMS Authentication Issue

SOLVED
Highlighted
Here to help

SMS Authentication Issue

Hi All,

 

We have an issue that has been raised by some of our branches re our guest WiFi which uses the SMS authentication.

 

Users are prompted to enter the authorization code that had been SMS'ed to them, but when they leave the splash page and go to the messages app to retrieve the code the screen to enter the code is gone and they need to request a new code, so they enter a loop. This has been reported and tested on iPhone, i haven't done any testing on Android.

 

The only "work around" we have at the moment is to do the drag down to preview the message, this isn't however ideal for all users.

 

Any thoughts?

 

Cheers

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Here to help

Re: SMS Authentication Issue

Hey Gallon,

 

We figured out a fix for this.

 

Under Wireless > Access control about halfway down the page there is a drop down for "Walled garden" when you have a splash page enabled. You should set this to "Walled garden is enabled" and put the "*.apple.com" domain in the "Walled garden ranges" section.

 

Then all is right in the world!

View solution in original post

4 REPLIES 4
Highlighted
Here to help

Re: SMS Authentication Issue

This worked before seamlessly? Is it just 1 user of multiple who're having this problem? 

 

First thought it seems like a cache problem between Twilio (or other 3rd party SMS provider) and the Meraki API. Have you raised a ticket with support?



Anima Sana In Corpore Sano
helpful comment? Get me some kudos 🙂
Highlighted
New here

Re: SMS Authentication Issue

I´m currently facing the same Issue here...

 

 

Highlighted
Here to help

Re: SMS Authentication Issue

Hey Gallon,

 

We figured out a fix for this.

 

Under Wireless > Access control about halfway down the page there is a drop down for "Walled garden" when you have a splash page enabled. You should set this to "Walled garden is enabled" and put the "*.apple.com" domain in the "Walled garden ranges" section.

 

Then all is right in the world!

View solution in original post

Highlighted
Just browsing

Re: SMS Authentication Issue

Hi!  We are facing the same issue with SMS and Iphones, users go to messages and loose the splash page.

 

What i dont understand i how your solution makes this work. cannot see the link between loosing the splash page and accessing the "*.apple.com" in the walled garden.

 

We tried it with no luck

 

thanks!

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.