cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Meraki AP on non Meraki switch

SOLVED
Highlighted
New here

Meraki AP on non Meraki switch

I believe the answer is yes but I just wanted to confirm.  I dont need to use a Meraki switch or FW to deploy an AP in my environment correct?  I have multiple Cisco switches and wanted to use 1 of those if at all possible.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
A model citizen

Re: Meraki AP on non Meraki switch

The port config on the Cisco classic switch can look like this:

 

interface GigabitEthernet1/0/19
description WAP
switchport trunk native vlan 90 (if accesspoints are in a own VLAN)
switchport trunk allowed vlan 50,52,90,300,301 (VLAN for accesspoint + VLANs for the SSIDs)
switchport mode trunk
spanning-tree portfast trunk

View solution in original post

9 REPLIES 9
Highlighted
Kind of a big deal

Re: Meraki AP on non Meraki switch

That is fine, as long as it supports the same PoE standard for powering it (for example, 802.3af, 802.3at).

 

Check the spec sheet for the AP model you are looking at, and then your switch spec sheet to make sure it supports it.

Highlighted
New here

Re: Meraki AP on non Meraki switch

Worse case scenario I need to get power or PoE injector than.

Highlighted
Kind of a big deal

Re: Meraki AP on non Meraki switch

Correct.

Highlighted
A model citizen

Re: Meraki AP on non Meraki switch

We have got Cisco Catalyst

 

WS-C2960S-48LPS-L

WS-C2960X-48LPS-L

WS-C3560CG-8PC-S

 

All with PoE+.

It´s working with them.

Highlighted
Here to help

Re: Meraki AP on non Meraki switch

Yes, the answer is YES 🙂

You can use every switch but if you need to deploy multiple SSID in different VLAN you need your switch is manageable.

Anyway consider the full-stack configuration (meraki firewall-switch-ap)  to have the top overview of your networ 😉

 

Regards,

Highlighted
Building a reputation

Re: Meraki AP on non Meraki switch

Prior to getting our Meraki switches we had a bunch of Linksys/Cisco and HP switches some with and some without PoE - worked fine using the power supply provided with the AP.

 

Meraki switches purchased as part of new IP phone system which needed PoE for the new handsets.

 

New switches enabled a simple and easy VLAN setup and enabled the removal of the wall warts and allow us to use PoE for the AP 🙂

Highlighted
New here

Re: Meraki AP on non Meraki switch

I have 2960-L and 3650's for my home network.  I figured I would be fine but didnt want to assume.

Highlighted
A model citizen

Re: Meraki AP on non Meraki switch

The port config on the Cisco classic switch can look like this:

 

interface GigabitEthernet1/0/19
description WAP
switchport trunk native vlan 90 (if accesspoints are in a own VLAN)
switchport trunk allowed vlan 50,52,90,300,301 (VLAN for accesspoint + VLANs for the SSIDs)
switchport mode trunk
spanning-tree portfast trunk

View solution in original post

Highlighted
Meraki Employee

Re: Meraki AP on non Meraki switch

Just one other thought - make sure your Meraki APs can reach the Internet  (i.e. the Meraki cloud platform).

You may need to open some access for this through your network and perimeter firewall;   check out Help > Firewall info, from the Meraki Dashboard, for the holes you need.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.