ms425 loop

mikeos
Here to help

ms425 loop

I have a stack of 6 ms425 as my core and ms250 in stacks in the closet

 

I am connecting my first ms250 to the ms425 

 

I have Aggs on both ends that span switches in the stack

 

when I have 1 cable plugged in everything is fine but I only get 10g throughput and no failover

 

when I plug in the other cable in the agg ports on both ends the ms425 sees it as a loop and ended up crashing my entire stack of 6 ms425's that everything needed the power cycled 

 

I have a ticket open with meraki but they don't believe that the cable I plugged in was the cause of the loop

 

so i'll be doing it again with them this weekend to see it fail in action and maybe figure out why it is happening

 

just wondering if anyone has had this issue

10 REPLIES 10
UCcert
Kind of a big deal

Hi @mikeos ,

 

Are all your L3 VLAN interfaces configured on your MS425 core?  Is the core configured as your Root Bridge?

 

Switch > configure > switch settings

 

UCcert_0-1620136942371.png

 

Darren O'Connor | uccert.co.uk
https://www.linkedin.com/in/darrenoconnor/

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.

the layer 3 vlans are on the me425 and the core is set as the root bridge

 

this works fine when I use 1 of the cables

 

plugging in the second cable causes the entire thing to fail as it sees it as a loop not an addition to the agg group

I noticed the 12.28.1 firmware update and one of the notes states loop detection on the ms250

 

maybe it's a firmware issue

 

but I figured meraki to meraki would have been a seamless integration

UCcert
Kind of a big deal

hi @mikeos 

 

Meraki to Meraki generally just works.  I've seen some funnies in the past but have had no major issues over the years.  

 

What version firmware are you running?

 

Are you happy to share screenshots of your uplinks ports on both the 425 and edge?

Darren O'Connor | uccert.co.uk
https://www.linkedin.com/in/darrenoconnor/

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.

We are running 12.28 on everything

 

This is our first Meraki to Meraki setup

The core

mikeos_0-1620140765243.png

 

 

The edge

 

mikeos_1-1620140765253.png

 

 

In this configuration plugging in both edge ports causes a loop and took down a 6 x ms425-32 stack

 

UCcert
Kind of a big deal

HI @mikeos 

 

On your core AGG/Etherchannels change STP from Loopguard to Rootguard.

 

Also change UDLD to Alert only rather Enforce.

Darren O'Connor | uccert.co.uk
https://www.linkedin.com/in/darrenoconnor/

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.

I did not implement those changes as my meraki ticket said not to at this time

 

I did replace everything yesterday, cables, transceivers

 

I cleaned all the fiber 

 

the connection sat stable for almost 7hours

 

then it just said there was a loop and the connection keeps bouncing there have been 3 other loops detected thruout the night

 

I have turned off that secondary connection for now, 

 

very weird and the only suggestion from tech support is to buy their tranceivers

GIdenJoe
Kind of a big deal

So you checked your core stack is effectively operating as a stack?

So you put all those ports into stacking mode and connected them in a ring?

 

What happens if you don't use LACP.  Does it correctly block one link?

When you do use LACP, does the local-ID match on both links?

at this point I have replaced the gbics with meraki gbics 

 

if I plug in 1 cable it is stable for 7h or so then starts bouncing repeatedly every few minutes

 

I tried pluggin in just the second cable and it does the same thing

 

i'll update this ticket with a solution when I get one from meraki support

akh223
Getting noticed

We are seeing issues like this with a new set of MS425 cores also.  Did support ever give you any clues as to what was happening?  This is not our first MS425 stack, and the others seem to work correctly.

 

We are using MS225 stacks at the remote IDF's, and I did notice that for some reason, the Aggregate uplinks between the core stack, and the IDF stacks started to put one of the links in STP blocking as it started seeing a loop instead of an aggregate.

 

 

 

Hey AKH223 in the end the problem was we have om1 fiber in the building with lrm transceivers the issue was because the patch cables where dirty, nnot the right type and not plugged in correctly. once I had everything plugged in correctly with the right cables and transceiver and plug in the correct way with fiber conditioning cables we now have 30 closets stable at 20g per closet and has been rock solid hope this helps you out
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels