Very high proportion of CRC errors Meraki Switch

Here to help

Very high proportion of CRC errors Meraki Switch

I have problems with Switch Meraki MS225 and MS410


My Network using MS410 is core switch and using MS225 is access switch connect across buildings with fiber optic cables. The Problem is port on MS410 used connect with MS225 is alert "Very high proportion of CRC errors Meraki Switch" on this port. Then port MS410 is disconnect to MS225 and MS225 light status change from white light to orange light.


Anybody have any experience troubleshooting CRC error issues.


Thank you very much 



Screen Shot 2562-03-25 at 10.02.02.png

Screen Shot 2562-03-25 at 10.37.47.png


13 Replies 13
Kind of a big deal

This is basically telling you that you have a bad cable between the switches. Could be the SFP modules since that model FTLF1318P3BTL-C1 is showing as 'Finisar' which isn't a Meraki SFP. Or the fiber cable has some issues, but I would probably start with swapping out the SFP modules on both sides to ones that are Meraki products.
Nolan Herring |

As @NolanHerring said. Likely a bad or dirty SFP, bad or dirty fiber or an overly bent fiber patch cable (they have a maximum bend radius).

Could also be a mismatch somewhere. Make sure that all equipment on that path is spec'd identically. I.e. if you're using multimode OM4, make sure the SFPs are multimode on both ends and make sure that the patch cable is multimode (ideally OM4) too. Similarly if you're using single mode, everything should be single mode. In your case it's the latter so everything should be single mode.


Lastly, it could also be that you're near or over the max distance for that cable/speed. Take a look at the distances mentioned here:

Here to help

@NolanHerring @BrechtSchamp Thank you so much for the suggestions. I will check according to your suggestions.

I recommend cleaning the SFP's and fiber connections with one of these before you get too technical with the troubleshooting.


Edit: For anyone viewing this in the future, just google "Once Click Fiber Cleaner" if the link is dead.

Building a reputation

I have the same issue. Any updates ? 

In case i'm disconnect all port on switch and recheck physical port and cable. Then i'm reconnect one by one port for analyse CRC error. But after reconnected all port CRC error not happening again.
I think cause of issue is physical problems.
Kind of a big deal
Kind of a big deal

What grade of fibre is using used between the buildings?  E,g. OS1, OS2, OM3, etc.  What colour jacket is on the fibre?


Also is this newly installed fibre, or has the fibre been installed been in for a while and used with other switches?

New here

I have seen this issue multiple times now after reboots.  Whether it be a reboot after a firmware upgrade or a power outage.  Once it comes back up, the module ports will give that alert.  The first time I swapped the cable and figured it was hardware.  The next time I swapped two twinax cables, but thought it was odd that two would go out at the same time.  Since then I've noticed that the issue does only come up for us after power cycles.  Power cycling the port or re-seating the fiber cable usually does the trick.  


Aside from @nakarin , is anyone else noticing the same?


FORGOT TO MENTION: This actually happened to us this morning after the power in the building was being worked on and caused the switches to go down.

Building a reputation

I had this issue with a MS320, and eventually the SFP ports failed.  I only discovered it due to power outages during a construction phase, and then some extensive troubleshooting.

Here to help

Turned out to be due to the SFP

Here to help



I have a problem with the same error but when I connect a Cisco 7940 Series phone to my Meraki MS355-24 switch, when I connect the phone to the port, the port immediately blocks and I get the Very high proportion CRC error.

I have already used several different cables, but I don't know what is causing the error.


Thank you

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.