Problems with printers in different VLANs

Here to help

Problems with printers in different VLANs

Good morning everybody!


We are using Meraki MS210-48 switch, and we have printers in our office on the VLAN connected by ethernet.


We have also wirless public VLAN, with the firewall rules allow any any (IP from the printer)


All computers can reach and install them by lan, but Wireless only the Mac Computers can reach them.


We already put firewall rules (also tried on the WLAN rules), but if we are connected in different VLAN (by wireless), we can not reach them, by ping we can, but not for install them on windows.


Because in mac was working, we tried Bonjour assistant, and from the Wirless Public VLAN I can see them but can not install them (same as with ping).


Any suggestion would be appreciated.


Thanks everyone,


We found the problem, it was on a rule on the firewall. Just to inform, the printers should have 2 way rules. Go and comeback.

View solution in original post

Kind of a big deal

What is routing between your VLANs?

thats the point of Vlans Segregation, maybe you knew that but if Vlans cant talk to each other then there ya go.

The router that we are using is the one from the internet provider.


The firewall MX84 is used as a DHCP Server. Giving IPs in the different VLANs.

(We already applied the firewall rules to reach by ping the printers, not working for adding them to windows.)


Is it possible that we can give IP from different VLANs, but there is no connection between the VLANs becasue there is no routing between them? I thought this can be done from the Firewall. We have this in routing and dhcp configuration on SWITCHes: ( "You don't have any interfaces or static routes configured, Create an interface to configure layer 3 settings on your switch").


We have 6 switches, most of them with trunk ports, one of them is connected exclusively for the Wifi APs, who are giving the SSID that we want to use to set up for clientes to use the printers (are users BYOD).


Maybe the firewall can not route between the VLANs? 

In Addressing & VLANS the deployment is set as routed, and as a subnets we have the different VLANs...


We found the problem, it was on a rule on the firewall. Just to inform, the printers should have 2 way rules. Go and comeback.

Building a reputation

First thing I would do is turn off windows firewall and then see if the printers work.

Done, and it's not working 😞

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.