MS130 switches causing UDLD errors

redsector
Head in the Cloud

MS130 switches causing UDLD errors

I have a few MS130-8X switches and they are causing UDLD-errors at the port of the connected switch. Anybody here with the same issue? The uplink goes to an MS120 switch. The MS120 reports UDLD error on the port where the MS130 is connected.

21 Replies 21
cmr
Kind of a big deal
Kind of a big deal

Is this when using the SFP ports and a fibre?  We have a MS130-12X connected to an MS355-48X, but over copper.  That combination doesn't have an issue.

redsector
Head in the Cloud

connected by copper.

I did open an case for this issue. Will inform you as soon I have more information.

Meraki is still working on this issue. Ticket / case is in work.

joopv
Getting noticed

Are you sure that the cabling is OK?  If you ruled that out then ...

In rare circumstances, there are UDLD errors and spanning tree errors caused by a physical issue at the component level on only MS120's. It seemed to mainly be effecting ports 10/11, but after searching I do see some other scenarios where this happened with ports 3. The issue should only impact negotiation at 10 and 100mbps

redsector
Head in the Cloud

Shure good cables, I testet several used and new cables. Issue on alle copper ports. Issue occures also when connected with 1Gig speed.

chris674
Here to help

Hey there!  Seeing some weird UDLD issues with a MS130R switch that we have at one of our sites also.  Worked extensively with Meraki support, we troubleshot all layer 1/2 issues.  I put a MS120-8 port switch in place while Meraki sent a new MS130R.  That temporary switch had no issues at all, no UDLD errors.  I get the new MS130R, put it in, UDLD issues and switch goes down, I'd say every 6 hours to a day or so.  Engaged support again, but they are looking at layer 1 issues again.  Kind of starting to think the MS130(R) ruggedized switches may have a manufacturer defect or something.  Next step for us is to install MS120 again and perhaps move the MS130R to our main stack and connect via fiber there.  If it drops there too I would be extremely confident there is no layer 1/2 issues, and we're looking at faulty equipment DOA from Meraki.  Our uplinks are 1G fiber, SFPs appear to be on the compatible list for the switches.

 

Any luck with TAC on your case?

CoreyDavoll1
Getting noticed

This sounds like an issue that I'm having with a few of my MS130-48X's.  We're using the 10GbE Twinax cable (MA-CBL-TA-1M) for the switch interconnects.  Support suggested replacing the cables so we did that this morning and now I'm waiting to see if we see the same behavior.  I did notice today that when bring up the port settings that UDLD is showing Alert but the port profile is set to Enforce. 

 

Anyone else using Port Profiles?

Any update on your issue here Or any update from TAC

16.9 was just released which is supposedly fixing the control plane issue which they said is the root cause. We're deploying tonight so hopefully it resolves it.

I too am using port profiles but no issues there. I tried using one of the 2.5Gbps ports on my MS130-8X to connect to a SFP to RJ45 10Gbps module and still got the error... Meraki support says a fix is in the works but no ETA on the release of said fix yet. I can post screen shots of support if that gives anyone hope...

 

I am asking for them to extend the license on the MS130, as it is pretty much useless. It just randomly drops traffic and that is unacceptable. 

16.9 was just released which is supposedly fixing the control plane issue which they said is the root cause. We're deploying tonight so hopefully it resolves it.

I hope this is the fix.  I've got this upgrade for our network on the calendar after seeing your post.  Meraki TAC has been pretty useless thus far.  They keep insisting our fiber is bad, but it's not.  The MS120 I put in place to test with for two weeks didn't drop once.  Hoping this resolves it for you/us.  I am not using port profiles.

Yeah they had me replace my cables too.  I had the same symptoms last night so it doesn't appear to have fixed my issue.  Back to the drawing board I guess.

It‘s a mess. How long do my clients have to wait?

That's a great question.  My network refresh project is pretty much on hold until this is resolved.

I guess it hadn't resolved the issues

After a few settings changes that did not fix the issue.  Support is now saying that there is a fix in the MS17 code.  Waiting on details since the published beta still lists the control plane bug as a known issue

redsector
Head in the Cloud

Still UDLD-errors.

the newest beta-firmware still has this issue in "rare" circumstances 😂. Here on each place where MS130 are installed on different networks and places. Everywhere!

 

Switch firmware versions MS 17.1.1 changelog

Ms130 known issues

  • In rare circumstances MS130s may experience management plane congestion that results in UDLD alerts and STP transitions

My support tech replied back to me with "On our internal thread, our escalations team stated that they expected these issues to be resolved in the latest 17 beta firmware. The reason it's listed like this in release notes is that it's still in its verification stage as being "fixed"."

 

So I'll probably have it pushed and see what happens. 

AdamBillington
Conversationalist

Well at least it has now been identified and acknowledged. This only occurs with the MS130 model for me. 

Yeah I believe that its specific to the MS130 line.  I just bought a bunch of them for a refresh project.  I've paused the project until this is resolved unfortunately. 

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels