cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MS120-8 firmware upgrade not working

Here to help

MS120-8 firmware upgrade not working

Hi,

 

I bought a bunch of MS120-24 and MS120-8 units. A few of them have been upgraded to 9.36.

I have 1 specific MS120-8 switch i cannot upgrade from 9.32. I have tried to upgrade to 9.36 and from 9.32 to 10.15, but everytime it does not succeed.

 

As soon as the device starts the upgrade (led blinking white) all communikation through the switch stops and it never completes. It just sit there blinking white for hours. I have tried to factory default the device, but it does not help. I have tried to power cycle the device before upgrade, same issue.

 

When i downgrade to 9.32, reset the device, it boots up and runs 9.32 - only the config is downloaded, as no white blinking start, which must mean, it is already on 9.32.

 

So now i am afraid to upgrade any of the many others switches, i have.

 

Anybody seen this?

 

/Robert

 

18 REPLIES 18
Head in the Cloud

Re: MS120-8 firmware upgrade not working

I've never seen this behavior. Have you tried to power cycle the switch after the upgrade/downgrade process, I know that the MS line has a timer associated with the firmware upgrade/downgrade. I.e Firmware pushed, updated/downgraded then the device should reboot. 

 

If you're still having issues after this I'd advise to get in touch with support (help>get help) while going through the upgraded/downgrade process. They'll be able to jump on the device and see what's going on. If they can't resolve then I'm sure they'll provide you an RMA.

Eliot F | Simplifying IT with Cloud Solutions
Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Here to help

Re: MS120-8 firmware upgrade not working

Yep, power cycle does not help.

 

Kind of a big deal

Re: MS120-8 firmware upgrade not working

Have you tried factory resetting the unit with a paperclip? 

MRCUR | CMNO #12
Here to help

Re: MS120-8 firmware upgrade not working

Yes, both after and before upgrading ... i have tried every possible combination.

What i suspect happens is, the upgrade starts, but never does anything except cut off all communication. it blinks like it´s upgrading - forever - and as soon as i reset the device with a paper clip (and i have set it to downgrade) it boots up, fetches it´s configuration and keeps running with solid white led. If it was rearly downgrading, i would expect it to start flashing the led after a short while.

 

What weird is also as soon the led starts flashing - indicating it is upgrading - all communication is lost - which is not normal.

Kind of a big deal

Re: MS120-8 firmware upgrade not working

Sounds like it's time for an RMA. 

MRCUR | CMNO #12
Here to help

Re: MS120-8 firmware upgrade not working

I´ll open a case and see what they say ...

Kind of a big deal

Re: MS120-8 firmware upgrade not working

I'm with @MRCUR, RMA.

 

Otherwise you can check the "Local Status Page" during the upgrade.  It will give you a hint what it is up to.

https://documentation.meraki.com/zGeneral_Administration/Tools_and_Troubleshooting/Using_the_Cisco_M...

Here to help

Re: MS120-8 firmware upgrade not working

The local status page just shows it´s upgrading and never goes beyound 0% until the switch stops responding.

Unclaiming and reclaming the device to a new org. same the same result.

 

The deivce has now been RMA´ed.

 

Conversationalist

Re: MS120-8 firmware upgrade not working

Did the RMA help ? i have excessive issues with FW-upgrades on the 120 series. It seems s if depends somehow on the infrastructure you have in between... The 120 series rely on a new safe firmware upgrade process different than the successors... Did you try attaching it directly to a router without any firewall, tunnel, ... ?
Here to help

Re: MS120-8 firmware upgrade not working

Well, i got a replacement device but it took at least 3 hours to do the upgrade on this one.

Do I dare to upgrade the rest ??? 

Kind of a big deal

Re: MS120-8 firmware upgrade not working

What does the local status page of the switch show while it's upgrading? Are you using the latest 10.X build or 9.X still?

MRCUR | CMNO #12
Here to help

Re: MS120-8 firmware upgrade not working

Status page shows upgrading. I´m on version 9.x

Kind of a big deal

Re: MS120-8 firmware upgrade not working

As a tip @RVilhelmsen I tend to plug switches in for 24 hours at least a day before I need them - because yes, for some reason some time they seem to take ages to do their initial upgrade.

Here to help

Re: MS120-8 firmware upgrade not working

That´s a bit hard, when it´s in production.

Kind of a big deal

Re: MS120-8 firmware upgrade not working

I have seen MS devices get stuck upgrading and typically a factory reset will get them to upgrade properly. Obviously this isn't ideal for a switch in production, but you may need to go this route if it's refusing to update. 

MRCUR | CMNO #12
Here to help

Re: MS120-8 firmware upgrade not working

a factory reset did not help on my device ....

Kind of a big deal

Re: MS120-8 firmware upgrade not working

If it's still not updating after a factory reset, then you probably need to RMA it. 

MRCUR | CMNO #12
Highlighted
Conversationalist

Re: MS120-8 firmware upgrade not working

Are these switches directly connected to a router or firewall or is there some kind of tunnel in between ?

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.