cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ICMP not working across switch

SOLVED
Highlighted
Conversationalist

ICMP not working across switch

Hi,

 

I have recently installed a Meraki MS120 switch at a customer site.  the switch is uplinked to a Draytek router which is handling dhcp.

 

I have some windows devices and a printer connected to the MS120 switch.  they have all picked up a dhcp address fine within a 192.168.x.x range and all show the Draytek as the DHCP server.

 

The draytek router can ping the devices and printer fine.

The Meraki switch can ping the devices and printer fine.

However the devices and the printer (connected to the same meraki switch) are unable to ping each other.

 

the majority of the settings on the switch are left as default.

 

Not sure what could be causing this, can anyone help?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Kind of a big deal
Kind of a big deal

Re: ICMP not working across switch

Can you verify that not one of the ports  have Port Isolation enabled.

View solution in original post

6 REPLIES 6
Highlighted
Here to help

Re: ICMP not working across switch

Having dealt with a similar issue this morning, my first thinking would be are the relevant ports on the correct VLAN(s)?

Highlighted
Conversationalist

Re: ICMP not working across switch

Hi Marki - thanks for replying.

 

yes the customer's network is flat vlan network on Vlan 1.  Only one LAN on site 192.168.143.xx network and all devices are getting an IP in same subnet.

Highlighted
Here to help

Re: ICMP not working across switch

Hi Rsahni,

 

Can the devices print or transfer files between themselves or is there no connectivity whatsoever?

 

I would check they have the correct default gateway also.

Highlighted
Conversationalist

Re: ICMP not working across switch

Machines are on the network fine and can access other network services ok.  Ping is not working and local firewall on machines have been checked.

 

default gateway has been checked and is configured fine as .1 which is the router.

 

I am not on site so cannot do any further testing today but any other suggestions would be welcomed.

Highlighted
Kind of a big deal
Kind of a big deal

Re: ICMP not working across switch

Can you verify that not one of the ports  have Port Isolation enabled.

View solution in original post

Highlighted
Conversationalist

Re: ICMP not working across switch

Thank you, this was the issue.

 

I checked and majority of ports were set as enabled on port isolation.

 

I have now changed to disabled and have confirmation that all is working fine.

 

thanks for the tip! 🙂

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.