CRC errors

Rm000
Here to help

CRC errors

Hellos,

 

I had had this error ''High proportion of CRC errors on port 12'' for the past 12 hours. I have sorted the cabling problem and everything is okay but the error doesn't seem to go away. How long does it take to clear CRC errors? How can i clear them?

22 REPLIES 22
BrandonS
Kind of a big deal

Re: CRC errors

I'm looking at a similar situation right now. Have yours cleared yet?  I wouldn't worry about it much as long as they pass cable tests and are green for a while after repairing them, but I think someone has sorted the cable issues on mine and I still see an amber icon (not shown in my screenshot) and some red warnings:

 

Screen Shot 2021-04-23 at 11.32.12 AM.png

robint
Comes here often

Re: CRC errors

Hi, 

I've got the same error, on a MS120-24P, but what is strange is that I have nothing connected on the switchport.

The warning is still here after 6 hours.

It happened after a restart of the switch.

 

So no issue, but I don't like to see my switch in orange warning in my topology.

 

If anyone knows

 

 

 

cmr
Kind of a big deal
Kind of a big deal

Re: CRC errors

What firmware versions are you running, I have two MS225s that are both showing this in multiple ports.  One port that is coloured green, but labelled as high CRC errors has had a total of 1 error over the last day.  One of the ports is coloured red and that has 14k CRC errors so is labelled very high which I think is fair!

 

These are running 14.16

 

I have many MS210s, MS120s and MS220s running the same firmware but not showing the same, yet prior to 14.16 we didn't see this anywhere from memory...

BrandonS
Kind of a big deal

Re: CRC errors

MS120-24P running 12.28 for me.  Mine is a new install and has Meraki MX, MV and MR that all connected up fine and nothing but green. Our team ran the cable and tested it clean.  Then some A/V and satellite TV teams showed up and that is when I started seeing this.  I figured it was their gear or their poor terminations somehow.  Now I am less sure about that.

 

 

rqbillo
Conversationalist

Re: CRC errors

I have the same error. Everything seems fine but the alert keeps popping up. Coincidentally, the alert only points to ports on a specific LAN.

robint
Comes here often

Re: CRC errors

I'm running a 12.28 Firmware, and 1 fragment error.

The error is still here 24h after, and no way to reset it.

I don't remember having seen this before

Rm000
Here to help

Re: CRC errors

 Yes, the error clears after 24+ hrs on their own

Rm000
Here to help

Re: CRC errors

From observation, once the switch detects the error even after sorting the cable problem and disconnecting it from the switch the error doesn't go away. it takes 24+ hours for it to clear on its own

 

cmr
Kind of a big deal
Kind of a big deal

Re: CRC errors

@Rm000 it definitely seems to be more than a day as I had one error or a port on Saturday that now shows 0 errors for the last day, but is still showing High CRC errors on the port, a second port had a lot of errors on Saturday, 0 in last day now, but still show very high CRC errors

Rm000
Here to help

Re: CRC errors

 

Firmware version 12.33.

 

All switches with the same error all have a CRC count of 1

Rm000
Here to help

Re: CRC errors

I think it is a programming error or bug that Meraki needs to look into it. Anytime the CRC counter is greater than 1 we get the error which doesn't clear even when the counter is 0

Ron-Sungard
Conversationalist

Re: CRC errors

I have the same problem on a trunk. There was a genuine problem on the port that was cleared, but the alert would not clear even after 24 hours, so I moved the the connection to an adjacent port to test, and got no alerts on that port. The switch still reported alerts on the now vacant port. My switch version is 12.33

RonReid
ForrestDean
Just browsing

Re: CRC errors

Does anyone know if Meraki is working on this problem?

 

I'm about to submit a trouble ticket with them since I haven't found a solution online anywhere.  I've been getting CRC errors on 11 switches across my network since last week or the last 5 days and they won't clear.  I'm even getting CRC errors on ports that have no cable plugged into them.  I tried rebooting the switches as well as powering them completely off and then powering them back on.  I even disabled the ports that are reporting the CRC errors and the errors just will not clear.

Ron-Sungard
Conversationalist

Re: CRC errors

I haven't raised a ticket on the issue. I was hoping it was just an alert history issue and the alerts would clear of their own accord but it looks like a bug. I've only just moved my trunk to a different port so I have to wait an see if the switch stops alerting tomorrow.

RonReid
rqbillo
Conversationalist

Re: CRC errors

Hello,

I requested a ticket and this is what I was told "The issue was related to a backend change made by the development team last week. It has recently been resolved. If you disable the port for a while and re-enable it, do new alerts appear?" 

So what I did was update the firmware to version 12.33 and then used the option to cycle the ports that had problems. And a few hours later the alert disappeared. 

 

ForrestDean
Just browsing

Re: CRC errors

Is 12.33 a stable version?

Rm000
Here to help

Re: CRC errors

We upgraded to version 12.33 3 weeks ago, apart from the alerts that take forever to clear up everything else is okay. According to me it is stable as compared to the previous versions

hongquangdam
Conversationalist

Re: CRC errors

Hi,

 

I am also having the same problem right now.
Some MS are displaying warnings and I don't know how to clear them.

 

clipboard_image_958b0c82.jpg

Ron-Sungard
Conversationalist

Re: CRC errors

Follow up on my post. With the port disconnected, the alerts cleared on the switch after a few hours. As mentioned, the alerts would not clear while the port was active. Meraki needs to put out a notification for this.

RonReid
ForrestDean
Just browsing

Re: CRC errors

Ok, so I updated the firmware on all my switches on the network to 12.33 at 6 am this morning and all the CRC errors cleared.  I didn't even have to cycle any affected ports.  I'm not sure if this will work for everyone, but it cleared up my problem that persisted for almost a week until I applied the firmware.

BrandonS
Kind of a big deal

Re: CRC errors

Well, this is weird.  I just checked the one MS120-24P that had noticed a couple ports like this for a week or so now and as far as I know no one touched it and now the ports are green and the red warnings are gone, but I still see CRC errors in the last day.. in the packet counters.  I suspect Meraki is aware and trying some tactics behind the scenes to fix this since it seems quite widespread.

 

 

cmr
Kind of a big deal
Kind of a big deal

Re: CRC errors

Switches all showing green for me now on 14.16 so I'm pretty sure that the warnings have been turned off in the dashboard while a fix is worked out...

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.