cancel
Showing results for 
Search instead for 
Did you mean: 

Get Networks returning 404

SOLVED
New here

Get Networks returning 404

Hi,
I'm new with Meraki API and so far the only working GET so far is about my organizations, but when I try to get the network (using the ID retrieved from the previous get), the response i 404

https://api.meraki.com/api/v0/organizations/xxxblablablaxxx/networks ]

Why? the Organization ID is correct...  I also tried with a sample Org_ID I found on Meraki Postman start guide, and it works of course. So, is it due some missing permission? What should I check?

 

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Building a reputation

Re: Get Networks returning 404

Does your account have full access at the organization level (not at the network level)?

5 REPLIES
Building a reputation

Re: Get Networks returning 404

Make sure the Dashboard API is enabled for your organization.  Go to Meraki Dashboard > Organization > Settings.  Look for the "API Access" setting.

New here

Re: Get Networks returning 404

Already enabled, I also generated a brand new key and used in the place of the first key.

 

meraki code.PNG

 

 

 

The GET Organizations is the only one working...  Y_Y

Building a reputation

Re: Get Networks returning 404

Does your account have full access at the organization level (not at the network level)?

Head in the Cloud

Re: Get Networks returning 404

I think that is it. If I give myself "None" in organization and "Full" for the specific network then I can list my orgs, but can't actually fetch the networks.

New here

Re: Get Networks returning 404

Bingo... I have Read Only permission, indeed. I though that simple GET request would have been allowed, at least.

Thanks