slow Upload Download is fine

Getting noticed

slow Upload Download is fine

We have a new mx250 install on a network with symmetrical gig fiber.


We get 800-900 mb down but only 20 up. This is on wired and wireless. I checked and there is no traffic shaping enabled and no content filtering.


This happens on upload of files and multiple speed test sites.


Any advice would be appreciated.

Building a reputation

Anyway you can test without the MX in place? Or perhaps plug directly into the circuit and test it that way? If it’s consistently 20 then something is misconfigured somewhere. My bet is on the circuit itself.


If I plug into the circuit directly all is happy up and down. Only when the MX is in the picture does it get wonky.

Hi @NJacobe thanks for the update, so I'm assuming you mean that's even when you place a wired client on one of the LAN interfaces on the MX itself and run a speed test from that client machine, you're being held to 20Mbps upstream? But when you are bypassing the MX, you're getting several hundred Mbps upstream out of that same ISP circuit?  If so, and in the absence of any other configuration changes, I'd first check if the behavior is exactly the same when moving your ISP circuit from WAN1 to WAN2.  Then I'd get a case open with Meraki Support and let them dive into this and monitor the MX while you run that speed test from the LAN side of the MX, and advise them of any changes you noticed when using WAN1 vs WAN2.  Keep us posted.  

Kind of a big deal
Kind of a big deal

Have you made sure that the MX WAN port is properly configured as below:



Getting noticed

Yup they are setup close to that. I think we have it set to the default of 4gb and I know we manually dropped it to 1gb as well.

Yup if I plug into the lan ports I get the same result. I moved the wan 1 to wan 2 and get the same restult. 


If I plug my laptop into the ISP and bypass the mx I get full speed, 900mb up 900 down.  


Looks like I might need a case. I can't see anything with the config that would cause this. 

Head in the Cloud

Hi @NJacobe 

Few more ideas.

1. Could you please try updating the firmware? If already not.

2. Could you please try Negotiating the the WAN Interface speed Manually by logging into the Local Status page? ( I think we have the option to configure this. Not sure though)

3. Hope the Transceivers are from Meraki?



@NJacobe  The only other thing I can think of is that since the MX250 has SFP+ based WAN ports, instead of just moving the SFP transceiver from WAN1 to WAN2, have you tried a different SFP+ transceiver?  And perhaps regardless if it happens to be a copper or fiber SFP, a different patch cord just to rule out a pesky L1 issue?  Also confirm you don't have a duplex mismatch and re-confirm both sides are running 1000/full for example.  If the SFP and cable swapping has also been tried and speed/duplex confirmed, I think this thread has covered all the initial triage and obvious stuff, then it's time to get a case open, keep us posted on the findings.


@MerakiDave  yup I tried a couple of different SFPs just to rule them out. Same result. 


Tried new patch cables and verified that the ISP has it set to auto 1000. 


I'll open a case and see what's up. What's strange is the speed test and file downloads won't budge past 20 up. It's almost like a cap somewhere. I don't get that diectly connected to the ISP. 


I'll post of meraki support finds out what the issue is. Thanks! 

Kind of a big deal
Kind of a big deal

Is it a 1Gb SFP transceiver or a 10Gb one?  We use MX250s on the 15x firmware with 1Gb transceivers and have never had an issue.

Getting noticed

It's a 1gb transceiver. I did know there was a 10gb one. 🙂

It's also meraki "certified" version.

Thanks for the updates @NJacobe it sounds like we've collectively ruled out everything we can, time for a case, let us know what it turns out to be.  I agree it's especially odd the uplink is being held to 20Mbps, almost sounds like the typical asymmetrical traffic shaping many ISPs use, but when you bypass the MX it's gone, yet the MX had no traffic shaping rules in place.  One last thing - we didn't overlook a group policy did we?  The MX firewall and traffic shaping page might not have any settings, also make sure you're client isn't being tied to a GP that might be enforcing limits.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.