VPN Client Connection Issue on Windows 10

Just browsing

VPN Client Connection Issue on Windows 10

I'm using CISCO Meraki MX84 Firewall with all the required configurations to connect to it's VPN server (both at MX and client side i.e. Windows 10 VPN). But I have been un-successful in establishing a VPN connection.  


I have been reading lots of articles about similar issues but none of them could help me troubleshoot the issue. It is also very strange that I can establish a VPN connection to the same using my Android phone without any problem. 


Following message is received when I try to connect to VPN on Windows 10 computer:



The Windows Application log shows error: 

CoId={E0A1B9A4-71CA-0002-1F6F-A3E0CA71D901}: The user SYSTEM dialed a connection named MyVPN which has failed. The error code returned on failure is 809.


Any help in resolving the issue will be highly appreciated. Thanks

7 Replies 7
Just browsing



Thanks for your reply. Yes, I have already tried everything mentioned in the article but still can't find a success on the VPN issue.  

Getting noticed

Had the same issue. After creating the registry key and rebooting the issue was resolved.

I have already added the key but still get the same issue. 

Kind of a big deal
Kind of a big deal

Have you installed any recent Windows updates? if yes try to uninstall the update.


Have you thought about using Anyconnect?

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
Kind of a big deal
Kind of a big deal

Use rasphone.exe to start the VPN.  It gives better diagnostics.


Basically - the configuration on your machine is probably wrong.  You can use this tool to create a powershell script to correctly re-create the VPN connection.



Just browsing

Thanks all, the issue has been resolved after removing antivirus. It had firewall blocking the ports. 

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.