cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Source IP and/or VLAN mismatch

Getting noticed

Source IP and/or VLAN mismatch

HI!

Very recently I began seeing a lot of Source IP and/or VLAN mismatch entries related to when devices such as computers and VoIP phones are plugged into the LAN.  When that happens, the device cannot connect to the LAN and cannot access the Internet. 

 

We have a MX-100 and 4 HP layer-3 switches, and MR-16 APs.

 

The MX-100 is configured with 3 VLANS 20, 26, 121.  Two HP switches are daisy-chained to port 3 on the MX, which is set to VLAN 20. The other two HP switches are  daisy-chained to port 7 on the MX, which is set to VLAN 26. The third VLAN is currently inactive.

 

There is not a physical connection between the two sets of switches and I don't allow any other VLAN traffic on those ports.

 

Network jacks are duplex jacks...one is for VLAN 20 and the other for VLAN 26. 

 

This issue just started out of the blue even though this configuration has been in place for months.  Also the LAN performance has become terrible.

 

Any thoughts?

5 REPLIES 5
Kind of a big deal

Re: Source IP and/or VLAN mismatch

This typically happens when a DHCP device attempts to re-use its existing IP address (from another VLAN) because it is still inside of the DHCP time period when first plugged in.  When their attempt to renew their DHCP address fails they then release it and try and get a new address.

 

I've seen this happen most frequently with Apple devices, especially iPhones attached to WiFi.

 

Sometimes you get this on notebooks that people have had plugged in on a different layer 3 domain (such as home).,

JMD
New here

Re: Source IP and/or VLAN mismatch

We are seeing this recently on our MX64. We have a vlan for all cell phones. The computers connecting to the LAN are the devices getting this error. Our refresh is setup for 10 hours on the DHCP. Logging into the network offsite has become extremely slow. I am not sure where to go with this. Any suggestions?

New here

Re: Source IP and/or VLAN mismatch

Hi, I have the same problem. Do you have already fixed it or not? 
How have you fixed that issue?

Here to help

Re: Source IP and/or VLAN mismatch

i have those in my network also, but it comes down to our where we have vlan mismatch on each end or the native vlan is not the same across the board. If you have issue with pc and voip. This will cause issue expecally if you dont have DHCP option 150.

Getting noticed

Re: Source IP and/or VLAN mismatch

I had an issue before where my MX84 was passing CDP/LLDP packets from the switches across VLANs and causing "VLAN mismatch" errors. It caused my switches to shut down those ports because they thought they were connecting to themselves.

 

The only way I could solve it was setting those uplink ports as VLAN trunks.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.