Showing results for 
Show  only  | Search instead for 
Did you mean: 

One-Armed Concentrator - BGP

Here to help

One-Armed Concentrator - BGP

Hi All,
I’ve been having issues getting one-armed concentrator BGP working correctly, and am looking for advise / feedback from anyone who has implemented already.

Establishing BGP with the upstream device (3560v2 switch in lab env, ASR9k in prod) is straight forward enough, the issue is that our MX sends its BGP updates with a bogus next hop of (the concentrator’s real IP is in this environment). Actually, I observed in PCAPs that the correct next hop is initially sent, then 5 seconds later, a further update is sent by the MX with the bogus 192 address…


The upstream device rejects the prefixes as the next hop is not connected:
Oct 24 02:16:34.247: BGP(0): rcv UPDATE about -- DENIED due to: non-connected NEXTHOP;


I have had the same occur in two separate Meraki Organisations where I have tried this. Support tell me it is an intermittent bug which seems to have been around since v13.9 (first BGP release), but still no ETA on resolution.


I have configured a route map to set the correct next-hop IP to work around the issue, though I would expect it to send the correct next hop all the time...


Has anyone else hit this issue, or did it just work (ie, send the correct Next Hop address)? Have others done as I have, and worked around the issue? Has this proven to be a stable solution?

Thanks for any comments!



Here to help

Re: One-Armed Concentrator - BGP is an IP range reserved for documentation (as per RFC5737).


So definitely sounds like a bug!


Can you try using OSPF instead?

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.