cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No-NAT behavior with LTE failover

SOLVED
Head in the Cloud

No-NAT behavior with LTE failover

Gentlemen,

 

I just did some testing with an MX67C and its integrated LTE modem. The modem itself including failover to LTE is working as expected, until I disable NAT on both uplinks (which is what is needed in this scenario). It looks like there‘s some kind of connection between both, unfortunately I‘m unable to troubleshoot currently because of the „missing“ uplink.

 

Therefore: has somebody else tried to use LTE failover combined with No-NAT? Or is there some kind of secret switch that support can enable that excempts LTE from No-NAT? Or am I completely wrong with this assumption? Any hint is highly appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Head in the Cloud

Re: No-NAT behavior with LTE failover

Sorry to be answering this by myself, but perhaps this will help somebody someday:

 

Actually, it is working as expected right now! Seems like the cellular connection was kinda flaky with my first tests. I simply disabled No-NAT for WAN2, made sure I had a stable LTE signal  and everything worked flawlessly.

 

Strangely enough, it doesn't seem to work when WAN1 is set to No-NAT. I know you guys aren't too happy with the way No-NAT is implemented currently but this could be something to remember when developing this further.

 

Thanks a million @Raj66 for the hint!

View solution in original post

4 REPLIES 4
Highlighted
Meraki Employee

Re: No-NAT behavior with LTE failover

@CptnCrnch That is a good observation. I have never tried this but I feel like cellular kind of assumes itself as the secondary uplink during the time of failover. Can you try enabling No-NAT only on the primary uplink and see if that makes any difference to this behavior?

 

Cheers!

 

Raj

If you found this post helpful, please give it kudos. If my answer solved your problem, click "accept as solution" so that others can benefit from it
Highlighted
Head in the Cloud

Re: No-NAT behavior with LTE failover

Hi @Raj66 ,

thanks for stepping in, highly appreciated! Sorry it took a little to test again, it's not that easy to find a timeslot for a possible downtime.

Just as you proposed, No-NAT was only enabled for the primary uplink and the MX was forced to switch to cellular. This time, I had a backup connection (on my laptop) to see what's going on in the dashboard. Unfortunately, it looked like cellular wasn't taking over this time at all so the connection was lost completely.

Guess I'll have to step back and troubleshoot the cellular connection first.

Highlighted
Head in the Cloud

Re: No-NAT behavior with LTE failover

I was able to do some more testing now with only WAN1 being No-NAT enabled (OS is 15.15):

 

1) The MX itself was failing over to cellular as expected. I could see the mobile providers' IP on the dashboard

2) On the local MX status page, the connection was also showing up as "Connected", the speed test had some good results

3) Strangely enough, the dashboard didn't provide any information about the cellular connection at that moment

4) No internal client was able to access the internet though

 

I guess it's really narrowing down to the No-NAT feature.

Highlighted
Head in the Cloud

Re: No-NAT behavior with LTE failover

Sorry to be answering this by myself, but perhaps this will help somebody someday:

 

Actually, it is working as expected right now! Seems like the cellular connection was kinda flaky with my first tests. I simply disabled No-NAT for WAN2, made sure I had a stable LTE signal  and everything worked flawlessly.

 

Strangely enough, it doesn't seem to work when WAN1 is set to No-NAT. I know you guys aren't too happy with the way No-NAT is implemented currently but this could be something to remember when developing this further.

 

Thanks a million @Raj66 for the hint!

View solution in original post

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.