Meraki Client VPN - cannot connect on certain WIN 10 computers

Comes here often

Meraki Client VPN - cannot connect on certain WIN 10 computers

Hello all, 


i'm dealing with strange issue. Some users cannot connect via Client VPN - they are getting THE L2TP connection attempt failed because the security... I googled it and there was a bug caused by Win update year ago and it was fixed by KB. However this seems not to be my case. This seems to be affecting Windows 10 Business 21H2.


 I have noticed that responsible service IKE and AuthIP IPsec Keyring Module is completely missing for them, it doesnt exist... When i stopped this service on my PC i got same error. 


Did anyone face similar issue? Any help would be appreciated.



7 Replies 7
Kind of a big deal
Kind of a big deal

The Microsoft VPN client is too much work to maintain and keep going.  I'd cut your loses and buy some Cisco AnyConnect licences.  It's rock solid. 

Yes, anyconnect is best VPN client, it is working flawlessly also on Meraki. However, now it will be really hard to explain to customer that they need to buy license because of broken Microsoft... Its bit sad that Cisco Meraki doesnt give some free Anyconnect licenses as they did with ASA... 

Try using my VPN Wizard to create a powershell script to create the VPN on Windows 10.  It sets several registry entries and might fix the underlying issue for you. 

We have tried everything. As i mentioned, this has something to do with Windows 10 Business 21H2 pre-installed on HP laptops. Our customer also has Win 10 Pro 21H2 and no issues... 

Nvm, we have decided to buy Anyconnect Plus so we can be sure Windows wont break it again with some update....

Here to help

Buenas tardes, que version de Windows ocupas??

Tengo un caso similar pero lo estoy realizando en una version de Windows 10 Home

Quiero pensar que es eso por no ser no una version de Windows 10 Pro

Well, from my experience only Windows 10 Business 21H2 (19044.2486) pre-installed on HP laptops are affected. Other versions such as Pro, Home are working fine....


Kind of a big deal
Kind of a big deal

Have you tried with this software?

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.