MX85 VLAN with IPv6 only not Routing (to the WAN/Internet)

Comes here often

MX85 VLAN with IPv6 only not Routing (to the WAN/Internet)



i have an MX85 with IPv4/IPv6 at Configured at WAN1 (IPv4 is Static / IPv6 is auto).


I want to  make a VM available through an Public IPv6 Adress wich i get from my Provider. I 've tried the following steps without succcess.


I configured a VLAN with IPV6 (auto) only. When I attach a VM to this VLAN we get an IPv6 LinkLocal-IP  (fe80) and an fe80 Gateway Addres via IPv6 DHCP from the MX. With this configuration nothing works. No Ping no DNS resolution. It only works if I enable IPv4 at the MX and the VM.

I have also tried to set manual IPv6 Adresses to the VLAN and the VM. This also doesnt work.

I 've noticed that there are no IPv6 default routes in the Routingtable of the MX. Do I have to set the up manually?
Could it be that IPv6 Only is impossible with the MX85?


I would be glad to hear some advice on this. Maybe someone has expierence with Meraki and IPv6.






1 Reply 1
Meraki Employee
Meraki Employee

The current implementation of IPv6 for the MX does not cover IPv6-only use cases yet. However, that is the path we are on.

Your setup does not work since the IPv6 host is not receiving a DNSv6 address. RDNSS is not enabled yet for RAs. When you turn on IPv4 for the host, the host is resolving DNS using DNSv4. This is common for dual-stack setups. Try adding DNSv6 manually for the host while getting the GUA address from the prefix delegation.

Please DM me your email if you want to engage further. And thank you for preparing for an IPv6-only future. 🙂

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.