MX in NAT Mode Behind ASA.

SOLVED
3ffdot
Here to help

MX in NAT Mode Behind ASA.

I have an MX84 that is currently in passthrough mode and behind a Cisco ASA and in front of a Cisco layer 3 switch.  When in passthrough mode the MX sources all of its traffic out of the WAN interface which isn't helpful when it needs to reach the AD server that is behind the layer 3 switch.  I want to put it in "NAT Mode" so that it becomes a layer 3 device however I don't want it to NAT anything since the ASA is handling all of that.  Is it possible to get the MX to be a layer 3 device without having to NAT all traffic to its WAN interface?

1 ACCEPTED SOLUTION

Accepted Solutions
3ffdot
Here to help

Re: MX in NAT Mode Behind ASA.

@PhilipDAth I've been reading up about that actually and I've requested the Beta firmware from support.  This is a much needed feature.

View solution in original post

3 REPLIES 3
ww
Kind of a big deal
Kind of a big deal

Re: MX in NAT Mode Behind ASA.

https://community.meraki.com/t5/Security-SD-WAN/MX-NO-NAT-15-3-15-4/m-p/13949

 

you can probably try it by contacting support but its not official released yet.

PhilipDAth
Kind of a big deal

Re: MX in NAT Mode Behind ASA.

There is actually a new "no-nat" mode of operation coming out (I don't think it is released yet).  If you ask support they might enable this option for you.  This allows you to turn the MX into a router.

3ffdot
Here to help

Re: MX in NAT Mode Behind ASA.

@PhilipDAth I've been reading up about that actually and I've requested the Beta firmware from support.  This is a much needed feature.

View solution in original post

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.