MX 105 not assigning DHCP IPs for VLANs

Solved
NickKova
Getting noticed

MX 105 not assigning DHCP IPs for VLANs

Hello,

I have setup of couple of Unifi switches, along with Meraki firewall. Meraki firewall has 4 VLANs one default with ID 1, and following VLANs with their respoective IDs: ID 10, ID 50 and ID 90. All Unifi switches are connected through uplink ports, and a first, all switch ports were configured to have native VLAN 1. Now I have set up DHCP server for each VLAN in Meraki appliance. I am getting proper DHCP IPs for native VLAN 1, meaning default network. But when I change port profile to have native VLAN for example 90 on one of the switch ports, no DHCP IP gets assigned to the device (phone). What could be a problem? Port 5 on Meraki is connected to one of the switches and configured as trunk with all VLANs allowed. Pictures are attached: 111.jpg222.jpg

Oh, and as additional information, I got some devices getting IPs for VLAN 90, but not all, even after power cycling the switch ports and rebooting the devices - phones, they are not obtaining IP addresses. I tried with the laptop, and it is assigning APIPA address. 

1 Accepted Solution
rhbirkelund
Kind of a big deal

Unless you have configured it on your VoIP phones, they have no concept of VLANs. If you wan't them to pull an address in the VoIP vlan (90) there are a couple of ways to do so.

I don't know Ubiquity switches, on the MX you set the navtive vlan to 1, and make sure you allow vlan 90 (and others if so) on the trunk port.

On the uplink port of the Switch to the MX you set the Native vlan to 1, and allow vlan 90 (and others) if so.

On the port connecting to the VoIP phone you either;

* set it to switchport type trunk with vlan 1 as native and vlan 90 as tagged

* set it to switchport type access on vlan 90

* set it to switchport type access on your data vlan and voice vlan to 90.

LinkedIn ::: https://blog.rhbirkelund.dk/

Like what you see? - Give a Kudo ## Did it answer your question? - Mark it as a Solution 🙂

All code examples are provided as is. Responsibility for Code execution lies solely your own.

View solution in original post

9 Replies 9
alemabrahao
Kind of a big deal
Kind of a big deal

What about the Unifi switch port? Are they defined as trunk? Are VLANs allowed?
 
It's probably a configuration issue on the switch.
I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

Thank you very much for your reply. Here are pics for switch port and uplink port on the switch: 111.jpg333.jpg

Why the native vlan is 90? Anyway, on the MX Port you must also change the Native VLAN to 90.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

Ah ok, so if I revert native back to default on switch port(s) for the phone, what should I set here: 444.jpg

I appreciate your time and help, thank you!

I have never worked with Unifi Switches, but taking a look on the documentation you have to set it to custom and select your default VLAN.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

Thank you. I have some phones that were connected and working on default VLAN1 before this deployment, and now I am doing changes to get the phones to separate VLAN. So I can see in Meraki there are still leases for VLAN1 for some of the phones. As there is no clear step to revoke leases in MX 105 other than rebooting the device, I will reboot the Meraki and see what happens. Thing is I have been doing before on other deployments same way without issues. Like setting native VLAN on each switch port intended for phones to VLAN for VoIP (VLAN 90) and it worked - it is same  as if I set switch port native VLAN to NONE and set custom tagged to VLAN for VoIP (VLAN 90) and LLDP turned  on with Voice VLAN set to VLAN 90. But here something is not right, so I will get back after rebooting the Meraki - afterhours. 

Were you not configuring the port where the phones are in VLAN 90?

 

I guess so, so if you haven't yet do so.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
rhbirkelund
Kind of a big deal

Unless you have configured it on your VoIP phones, they have no concept of VLANs. If you wan't them to pull an address in the VoIP vlan (90) there are a couple of ways to do so.

I don't know Ubiquity switches, on the MX you set the navtive vlan to 1, and make sure you allow vlan 90 (and others if so) on the trunk port.

On the uplink port of the Switch to the MX you set the Native vlan to 1, and allow vlan 90 (and others) if so.

On the port connecting to the VoIP phone you either;

* set it to switchport type trunk with vlan 1 as native and vlan 90 as tagged

* set it to switchport type access on vlan 90

* set it to switchport type access on your data vlan and voice vlan to 90.

LinkedIn ::: https://blog.rhbirkelund.dk/

Like what you see? - Give a Kudo ## Did it answer your question? - Mark it as a Solution 🙂

All code examples are provided as is. Responsibility for Code execution lies solely your own.
NickKova
Getting noticed

Hello guys,

 

Thank you once again for your time and effort.

Just to note, I marked @rhbirkelund answer as solution, as I already tried everything as @rhbirkelund, but was still having issues. Seems that the problem was faulty switch, that is all. No matter how you set up:

On the uplink port of the Switch to the MX you set the Native vlan to 1, and allow vlan 90 (and others) if so.

On the port connecting to the VoIP phone you either;

* set it to switchport type trunk with vlan 1 as native and vlan 90 as tagged

* set it to switchport type access on vlan 90

* set it to switchport type access on your data vlan and voice vlan to 90.

It should work and works on all switches except on the one that by coincidence I was using for testing.

Thank you very much, hope this helps someone else in the future. You guys are awesome💪.

Get notified when there are additional replies to this discussion.