DHCP fixed IP assignments

Just browsing

DHCP fixed IP assignments



I have configured some DHCP fixed IP assignments to several equipments at home (NAS, printer, laptops, etc.). Now I need to replace a mac address to one of this assignment (equipment replaced with a new one) but cannot do it. When I do try to replace the mac address I get this error:


There were errors in saving this configuration:

  • Cannot have multiple fixed IP assignments for MAC address "xx:xx:xx:xx:xx:xx".
  • The IP address is already assigned to another host.

I have done in the past where I did want to use the same ip for a new device and always worked. I have also tried to delete the assignment and create again but does not work as well. I do click on X and assignment disappears but once I do save the configuration I still see it there (although dashboard says changes saved on the green pop up).


Any idea?







9 Replies 9
A model citizen

Hi @MGianni


Did you try removing the existing assignment, saving, refreshing the page, and then adding the new one? Did you get that same error result? 


I've also ran into interesting browser issues from time to time and have been able to use another browser when it wouldn't allow me to change configurations. 

Found this helpful? Give me some Kudos! (click on the little up-arrow below) and If my reply solved your issue, please mark it as a solution 🙂

Yes, exactly those steps. Tried to remove, save, reload the page and they were back there after page reload. I have also tried to logout/login.


Actually haven't tried another browser. This makes sense as the error provided was something like "you cannot use the same mac on another ip address" or "this mac cannot be assigned to another ip address as it has been already assigned". It was not saying exactly this but more or less this was the meaning. Maybe it's a browser cache issue.


I will try with Chrome or FF later. I do normally use Safari.




Ok, it is not a browser issue. Just tried Chrome and FF and same issue.
Getting noticed

i wonder if another device on your network had grabbed or is using the address you wish to assign after you deleted it.

Kind of a big deal
Kind of a big deal

Try this extreme step.


Unplug everything from the LAN side, then power cycle the MX.  Now its dynamic DHCP table will be empty.  try re-assigning the fixed IP address and then plug everything back into the LAN.

I can do it but don't this it will fix what I am experiencing. Basically I have several assignments and cannot even remove theme. For example I am trying to remove some of the assignments clicking on the X close to them (when those devices are off) and save. After save is done the assignments reappear again in the list.


I cannot reset the configuration as I have a lot of stuff (including firewall port forwarding rules). This is very annoying. I remember that I have changed DHCP assignments in the past when replacing devices but now does not work.


I will open a case!




On a side note, I can add new assignments and those get saved. Cannot remove or modify existing ones.

Here to help



Have you heard anything about this issue?  I currently have 2 networks experiencing the same issue, with the exception that I'm not trying to replace a client but add a new one.


Do IPs assigned to a MAC in one network stay on that MAC in another network within the same organization???



Yes, they did send me an email that was a bug and they were aware of it. They have fixed after few days and works fine now. I could change ip/mac assignments.




Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.