Connecting MX64 to BT Infinity Internet

Not applicable

Connecting MX64 to BT Infinity Internet

Hi all,


I've just moved home and I am trying to get my MX64 connected to BT Infinity Internet to replace the BT Smart Hub. I've reset my MX64, connected directly to the device and entered my PPPoE username + password (they don't use one, you can put anything!). The MX64 will pick up a public IP, which I presume means it has authenticated via PPPoE? The device will show as connected to the Meraki cloud, but it is always showing as offline in my dashboard. I've read online that I need to tag my traffic with VLAN 101, when I do this the MX64 will not even pick up a public IP address. 


Has anyone else tried the above and successfully got it working? 


Kind regards,



Kind of a big deal
Kind of a big deal

If you browse to a web page do you get anything coming up?


I'm not from your country, and are not familiar with BT, but I have seen this issue when the ISP blocks certain types of traffic.  I have especially seen it with 4G carriers when a user exceeds their data cap, and the ISP puts up a nice web page telling the user this and prompting them to spend some money.


If the local status page is showing that the unit is online, and you are sure the ISP should not be blocking any traffic, open up a support case with Cisco Meraki.


Head in the Cloud

Hi Stephen,


Hope you have gone through the following blogs.

It seems these users were successful in connecting MX to BT Internet.


Kind of a big deal

Yes, the MX works perfectly well with BT Infinity. I have used a Vigor 130 modem in bridge mode to connect the MX to the Open Reach termination box.


However, unless and until I see it demonstrated, I say that the MX cannot pass the BT variety of multicast (BT Sport etc) correctly. Don't waste time trying to make the MX handle it.


The way I solved the problem was to put another security device between the modem and the MX and have that device direct the multicast stream to the appropriate devices.


It helps if the other security device can disable NAT on the port it uses to connect to the WAN port on the MX, although it appears not to be mandatory in most cases.


Robin St.Clair | Principal, Caithness Analytics | @uberseehandel

@Uberseehandel  Been having this issue since 2015. I install all meraki and took away BT boxes . Do you know if Virgin has the same issues as BT?

I do not know how Virgin Media distributes content from other content providers such as BT Sport. If they convert multicast to unicast (which would be expensive in terms of bandwidth across the network), then I would imagine that there is a very good chance that the Meraki stack would handle it.


I would ask/poke around in the Virgin biosphere to find out what happens.

Robin St.Clair | Principal, Caithness Analytics | @uberseehandel

@Uberseehandel Thx for the reply. Will be moving home shortly and try to find out how Virgin works with Meraki

Getting noticed

i have the same issue.
My MX64 will not pick up a DHCP IP address for love nor money on BT Infinity.
My installation has a BT VDSL modem with an Ethernet port that normally connects to the BT Home Hub.


I've used the following settings, Use VLAN tagging, id 101, PPPoE, use authentication - username bthomehub..etc, and any password.


All the console dashboard says is 'Oops looks like something isn't quite right' and reports no Internet connectivity.

How have you configured the uplink to the BT modem?

Robin St.Clair | Principal, Caithness Analytics | @uberseehandel

as my post above :-
Use VLAN tagging, id 101, PPPoE, use authentication - username bthomehub..etc, and any password.

Getting noticed

for clarity the DSL CHAP username that I used is


Because the MX does not handle multicast IPTV properly, I have put another gateway device ahead of the MX and the MX now uplinks to a LAN port on that gateway, so the config I currently have on the MX WAN port is not helpful.


However, I use a Vigor 130 modem configured as below:

  • VDSL 2 enabled (Tag value 101 - Priority 0)
  • PPPoE/PPPoA disabled
  • MPoA (RFC1483/2684) enabled (Bridge mode enabled)

PPPoE/PPPoA only needs to be disabled if using multicast IPTV (eg BT Sport), similarly MPoA is only enabled to assist with smooth multicast operation. It works perfectly.


The gateway appliance ahead of the MX has its WAN port configured:

The public IP address of the MX is passed through from the appliance it is connected to.


Before I had to put the additional gateway device ahead of the MX, it connected to the Internet in exactly same manner as the connection I have described above.


Most BT FTTC cabinets can handle Jumbo Packets, but BT PPPoE maxes out at 1520, so make sure Baby Jumbo Packets are enabled


Robin St.Clair | Principal, Caithness Analytics | @uberseehandel
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.