Cannot Access Network Drives from Different VLAN

SOLVED
Steve_M
Here to help

Cannot Access Network Drives from Different VLAN

I have an MX67 with a server containing network drives plugged directly into one port, and another computer plugged into another port. There are no switches involved. 

 

If I put the server and the other computer in the same VLAN, I can access the network drives just fine. 

 

However, if I put them in different VLANs, I lose access to the drives in the server. 

 

Does anyone know how I could address this? The use case for this would be to allow VPN clients in a different subnet to access the network drives. 

1 ACCEPTED SOLUTION
Steve_M
Here to help

I was able to access the network drives by using the IP address of the server, instead of the server name. Granted, the firewall in the server is disabled, and I installed a new switch, so I don't know if using the IP address alone would have solved the issue from the beginning. 

 

Thank you everyone for the comments.

View solution in original post

8 REPLIES 8
Brash
Head in the Cloud

What do your Layer 3 firewall rules look like under "Security & SD-WAN -> Firewall"?
Are you using any group policies for either of the two devices?

Steve_M_1-1668700921322.png

 

alemabrahao
Kind of a big deal

Try disabling the firewall on both, the server and workstation. Are you sure that you don't have any L3 firewall rule blocking It?

Here's a screenshot of the firewall.

 

Steve_M_0-1668700639247.png

 

alemabrahao
Kind of a big deal

In that case, I think you should open a support case.

n0tHiNg
New here

Whats is the setting at SDWAN > Addressing & VLAN > Per-port vlan setting

Steve_M
Here to help

I was able to access the network drives by using the IP address of the server, instead of the server name. Granted, the firewall in the server is disabled, and I installed a new switch, so I don't know if using the IP address alone would have solved the issue from the beginning. 

 

Thank you everyone for the comments.

alemabrahao
Kind of a big deal

Well, If you don't have an internal DNS server It makes sense, You need to set a DNS server on the VPN to translate the IP on the name. The problem here is that you never mentioned it before. Sometimes we need all details to help better.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels