cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't Connect to Client VPN behind a Ubiquiti EdgeRouter (ER-4)

New here

Can't Connect to Client VPN behind a Ubiquiti EdgeRouter (ER-4)

I know this might be a question for the Ubiquiti Forums, which I will try as well, but I have a client who is behind a Ubiquiti EdgeRouter 4 and they are unable to connect to the Meraki Client VPN. I'm unsure why this would be by default, but will continue to do research and ultimately post the solution here. Does anyone else have experience with Ubiquiti EdgeRouter products and the Meraki Client VPN? Thank you in advance.

5 REPLIES 5
Head in the Cloud

Re: Can't Connect to Client VPN behind a Ubiquiti EdgeRouter (ER-4)

Hi @loudmog 

 

I do not have any experience with Ubiquiti EdgeRouters.

However I am just trying to share a bit of information about Meraki Client VPN.

Meraki client VPN works on, UDP 500 and 4500.

Could you please make sure these ports are available for the service to work?

 

Also could you please share the error message you see while connecting?

 

You may also check the following Url (This documents most of the common errors with Meraki Client VPNs)

https://documentation.meraki.com/MX/Client_VPN/Troubleshooting_Client_VPN

Regards
Ajit
ajitsnw@gmail.com
https://www.linkedin.com/in/ajitkumarverma/
Kind of a big deal

Re: Can't Connect to Client VPN behind a Ubiquiti EdgeRouter (ER-4)

What IP address is the client device behind the ER trying to connect to? What happens if the client is connected directly to the modem and they attempt to connect?

 

I find heterogeneous M2M VPN connections easier to establish that the remote client connections.

Robin St.Clair | Principal, Caithness Analytics | @uberseehandel
Kind of a big deal

Re: Can't Connect to Client VPN behind a Ubiquiti EdgeRouter (ER-4)

Meraki uses L2TP over IPSec.

 

I see in the Ubiquiti forums that lots of others are having problems.  People seem to be saying there are firmware bugs preventing it from working.

https://community.ui.com/questions/EdgeRouter-Lite-IPSec-Passthrough/116cb858-8d57-4c44-94f7-87956f6...

Highlighted
Kind of a big deal

Re: Can't Connect to Client VPN behind a Ubiquiti EdgeRouter (ER-4)

Phil that is a three year old thread.

 

In my experience, most of the "bugs" reported by UBNT users result from misconfiguration. You would be surprised how often Lazarus fixes the problem ("miraculously, I turned it on one day and it just worked, I didn't change anything"). 

 

Good sources of information are 

 

https://help.ubnt.com/hc/en-us/articles/115005445768-UniFi-USG-Configuring-L2TP-Remote-Access-VPN

UniFi - USG VPN: How to Configure Site-to-Site VPN

 

There can be mismatches with encryption standards.

Robin St.Clair | Principal, Caithness Analytics | @uberseehandel
Conversationalist

Re: Can't Connect to Client VPN behind a Ubiquiti EdgeRouter (ER-4)

Do you have any vpn connections on the edgerouter itself.  If yes thats your problem.  

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.