iOS - WhatsApp Business - Contacts

NightyMUC
Conversationalist

iOS - WhatsApp Business - Contacts

Hello Community,

Managed iPhones with WhatsApp Business cannot access the iPhone's contacts.
When contacts are created in Whats App, after clicking on "Done", a page is displayed that looks like a contact page with all the data. However, this cannot be confirmed anywhere, only terminated with "Cancel".
I have already checked the restrictions several times, but can't find anything.
Does anyone have any ideas?

 

Cheers

NightyMUC

5 REPLIES 5
alemabrahao
Kind of a big deal
Kind of a big deal

I once saw a thread where they were having issues sharing contacts and photos after the Meraki MDM profile was installed. The issue was resolved by uploading a profile to the phone without active sync settings and manually setting up active sync.
It sounds like your issue may be related to the way contacts are being synced or social media is being blocked on your devices. I suggest you check your settings related to your firewall. I also recommend contacting Meraki support.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
ConnorL
Meraki Employee
Meraki Employee

Is WhatsApp a managed app? (i.e. pushed via MDM)? If so, you probably need to disable containerisation.

You can do this by adding the Restrictions payload and unticking "Do not containerize work data and contacts from unmanaged apps" and "Do not containerize personal data and contacts from managed apps".

 

ConnorL_0-1701274469238.png

If you're still facing issues and have an ActiveSync payload, make sure you untick "Use only in Mail".

 

NightyMUC
Conversationalist

Thank you very much ConnerL,

you have put me on the right path.

 

At first, I activated "Do not containerize work data and contacts from unmanaged apps" and "Do not containerize personal data and contacts from managed apps", but nothing changed.

 

Than I went into the Apps and unticked "Visible in SSP" and boom--> it worked

Huh, SSP is just the Self Service Portal - this tool allows users to install/push apps to their device(s) via a website. It might've just been a timing coincidence that this worked as it should not impact the device-specific permissions. 

 

Nevertheless, glad you got the issue resolved 🙂 

PhilipDAth
Kind of a big deal
Kind of a big deal

This is deliberate containerization.  It prevents "personal" apps and data from accessing "work" apps and data, and vice versa.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels