Unable to remove android devices from SM

New here

Unable to remove android devices from SM

We have begun having issues removing old devices from the system manager dashboard after they are removed from service. After choosing the device and selecting delete we get the confirmation warning and then the status spins but the devices never gets deleted. 


All of the devices in question are Samsung Galaxy phones running Android 7.0. We have ios devices as well and are able to remove them with no issues. 


We have tried moving the devices to a different a network which works but they still cannot be deleted. We have tried deleting them one at a time which doesn't work. Deleting multiple at a time doesn't work. Deleting the entire network they are in gives an error"Unable to save changes. Please try again."  and will not complete. 



Support is unwilling to help as we are on the legacy free plan. I'm at a loss. Multiple browsers, operating systems, users, and computers have been tested with no difference. 

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.