MDM for Interactive Tables

New here

MDM for Interactive Tables

Hi all,


Asking on behalf of someone in regards to interactive tables. We are trying to enrol our Sharp interactive tables that are running on Android 6 (they cannot be upgraded) - see link .


"afw#meraki" does not work when attempting to add a Google account through the settings, and restore the table does not bring up a Google account dialog at any stage. We tried to install SM Meraki by signing into another Google account, but then it asks to encrypt the device which halts our progress by stating "You must charge your device" - these tables have a built in battery that is connected to power almost continuously and have an 11 hour battery life... but it seems that the battery percentage isn't available to apps such as Meraki (it was neither visible when we tried to display it via the Systems UI Tuner on Android).


Anyway, just wondering how we can get around this. I wonder if we can get past the encryption and just not encrypt the device. I don't know if we can encrypt the device through the Android options... or, as I said, just not encrypt... as we can't get past this stage. We read something about ADB (see link ) but I don't know if this will help either. Really want to get these tables on some kind of MDM so if anyone has any ideas this would be helpful.



Kind of a big deal
Kind of a big deal

Most likely they are not running a "standard" version of Android, and consequently do not support MDM management in Device Owner mode - by any product.


You will probablt only be able to get them to run in BYOD mode.

I assume you have tried installing any updates that are available for them ...

 Yep, we have. There is no option to update the Android software, and there's only an OTA Manager which we have made sure is up to date.


How would we be able to run it in BYOD mode? Does that not also require encryption? Getting past the encryption doesn't seem to be an option due to the lack of visibility of battery "charge" - I assume their "custom" Android has hid this from applications.

BYOD mode is applied after the device sets up normally, so the encryption process can complete.  It does not offer as extensive control as device owner mode. 

Will this mean that by doing it this way, we won't get the encryption issue in that case?

When downloading the SM Meraki from the playstore and attempting to enrol using the enrolment code, it then went to the encryption screen where we couldn't move past this because of the battery issue.

Have you got a fairly "blank" profile at the moment?  Or have you got a bunch of settings defined already?

What about if you get the device to manually encrypt itself before installing the SM app?

I don't know if this is possible.. I'll have to check the Security settings on the device - it's, as you know, a "custom" android OS and on OS v6, so I don't know if there is an option to encrypt. If somehow that is possible to encrypt, will SM meraki ask to encrypt the device? I would presume not.


For the specific tag we created for the tables, it's pretty blank. But obviously we are managing a whole other bunch of devices fine. The profile/tag created for the tables is empty essentially.

Meraki Employee
Meraki Employee

Hey there, Connor here from Meraki Support.

Sounds like the device isn't reporting its charging/power state correctly to Google Play Services / Android. The encryption is done natively by Android rather than Meraki SM.

If Sharp have heavily customised the image of Android (which is likely) then it might not be possible to correctly enrol it at all. You may be able to first encrypt the device from the Settings menu, then try and enrol the device. If this still doesn't work, I'd contact Sharp honestly as they'll know what they have/n't tinkered around with to get Android on a table 🙂

Kind regards,


Connor Loughlin
Network Support Engineer

.:|:.:|:. Cisco Meraki EMEAR 🇬🇧

For reference, many questions can be easily answered by searching our online documentation:

Thanks Connor - will check the settings menu ASAP. If this truly isn't an option and doesn't work, I guess I'm out of options. I guess there's no way of getting past the encryption side of it? I think PhilipDAth mentioned about BYOD enrolment but I am not sure if that'll still insist on encryption when attempting to enrol?

With BYOD, the storage is still broken into 2 different partitions. Google requires all devices to be encrypted so unfortunately this will not work either.

"Google requires that Android 5.0+ devices be encrypted when using Android Enterprise. This is important for both general device security as well as application specific data security. More about it can be read here:"


Thanks Connor - if encryption is not possible through the settings, we'll complain to Sharp and tell them we can't install our MDM on here because of their software restrictions.


Much appreciated 🙂

Anytime mate 🙂

Whilst complaining, I'd ask them to update the Android build too - Marshmallow came out in 2015! Yikes...

I know it's pretty abysmal tbh.. I'm a software engineer and I can safely say there is no reason for them to be on such an old version of Android! But thanks for all the help 😁

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.