Issue Installing AFW After MDM Enrollment

Here to help

Issue Installing AFW After MDM Enrollment

My company has the 100 free Systems Manager licenses that we're attempting to utilize. Phone support told me I'm entitled to email/dashboard support for these licenses so I've put in a ticket, but no solution as of yet.

I have gone through the process of installing the SM app on multiple Samsung Tab E devices. On the first couple, I had no issues. On further devices I've had an issue that has cropped up more often than not. After enrollment in my network through the SM app, the configuration tab shows a yellow triangle next to "Install AFW Account". On a couple devices, I was able to tap the yellow triangle and successfully request AFW installation. On the rest, it always displays the message "invalid device id or no pcc user" when tapping the yellow triangle. On these devices, I noticed that google play services was not updating to the latest version so I pushed the latest version out to the devices using the apk and custom app options. This did not fix the issue. I've reset said tablets a few times as is mentioned in another thread on the Meraki community, but it has not helped.

Anyone have suggestions for fixing the "invalid device id or no pcc user" issue?

Kind of a big deal
Kind of a big deal

I don't know about these specific devices; but sometimes I had had to setup the device outside of Systems Manager, update the device to the latest firmware and software, then factory reset and enrol into Systems Manager.

I had previously attempted to update the firmware and software with the MDM software already installed which did not help. I took your advice and set up a tablet without the MDM software. The firmware/android OS had no updates and the google play services updated to the same version I had previously tried. Resetting the device and enrolling into MDM had the same problematic result: "Invalid device ID or no pcc user" when attempting to install AFW account.


Currently on Android 7.1.1.

Kind of a big deal

What version of Android are these devices running? AfW is a mess on 5.1 with SM currently. 


Hi MagruderMan


We have just had the same error and it appears to happen when the username/password is not correct.  The enrolment process continues but it will fail with the "invalid device id or no pcc user" error as there is not associated user for the device in the meraki framework.


If you get this error:   Log onto the meraki admin console, find the device and you will find there is no user associated with the device.  "edit details"  add a user, go back to the device, open the meraki app, refresh the config and then add the afw account.


Hope this Helps!


Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.