How to remove VPP app that was never installed but license used?

Comes here often

How to remove VPP app that was never installed but license used?

I pushed an app (Vernier Video Physics) to 3 iPads and didn't realize they were not compatible until trying to load them on the iPad. However, Meraki shows the licenses as redeemed for those devices. I cannot get Meraki to release those licenses so that I can put them on a compatible device.


Does anyone have any idea how I can do that?



8 Replies 8
Meraki Employee
Meraki Employee

Hello @CArmstrong 


Are you using VPP user assignment or device assignment to grant licenses? You can revoke the license from the users and make them available for other users from the dashboard. I am attaching a document here fo your reference.




If you found this post helpful, please give it kudos. If my answer solved your problem, click "accept as solution" so that others can benefit from it
Comes here often

We are using VPP codes and then assigning to devices (we are using the free version of Meraki). Meraki shows the codes in use; one to a specific device and two to unknown devices. The two devices are unknown because we tried to revoke the code.


I've told it to revoke the license but it won't do it. I cannot uninstall it from the iPad because it was never installed.


I scrolled up on the document you shared to the section on assigning devices, but it doesn't seem to address my particular issue.




@CArmstrong  if you set the scope to no devices and give it an hour or so you should be OK. make sure hte devices are on the internet so they can sync their profiles and release the licenses. 

Thanks, Blake.


Of the 3 VPP Codes that I had, only one is assigned to an actual device. The other two say they have been redeemed by "unknown device" (this is likely due to our attempts at removing them - we took the devices out of Meraki). For the one device that is known, I added it to the scope, verified the app showed in Meraki SDB, then removed it from the scope. The device no longer shows that app in Meraki SDB, but the VPP Code has not been released.


It is odd, because the app never installed on the device - it failed. I'm not sure what I'll be able to do on the other devices that are listed as "unknown".


I ended up purchasing another code and applying it to another iPad. It installed, but Meraki is reporting its status as "Not installed". The VPP code is redeemed.



hello @CArmstrong 


I have the same problem.

Has this problem been solved?


Even if I contacted the apple, I was told that it was a problem on the Meraki side.



Here to help



App is not installed on Device, but Meraki Console is installed status.

App Revoke Command does not work.







I solved this Problem following this way:


his advice.

[set the scope to no devices and give it an hour or so you should be OK.]

I tried to set blank scope, and then apple school manager(VPP) released AppLicense.



Comes here often

That never worked for me. I waited a day after removing the scope. 

In my case.
It was useless to delete the scope.
Release it by creating the Scope NoDevices(disabled) setting.


[System Manager]-[Apps]






Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.