Enrolling Devices Running Android 12

Here to help

Enrolling Devices Running Android 12

I have a Pixel 3a that was recently updated to Android 12 that I'm trying to enroll onto SM in Device Owner Mode. 

However, every time I scan the QR code and try to enroll, I get an error saying that it can't set up the device and to contact my IT admin for help. 

I've tried it on another Pixel 3a (also running Android 12) and got the same result.

Is there a workaround for this? Or is there no support yet for Android 12?

14 Replies 14
Just browsing


Please forgive me it this does not apply. All of our devices are Samsung

I have always started with a new phone that has never been set up or have to factory reset it and when it asks for the Gmail account I use afw#meraki which will set it up for device owner and install the SM app and then I either enter our id number in or scan the QR code for the android 6+.

Hope this Help

Thanks for the reply. I've actually tried this but it did not work, unfortunately.

Per Meraki support, this appears to be a known issue and is being worked on by their internal dev team. 

I'm curious if anyone running Android 12 has been able to successfully enroll their devices.

Just browsing

Hey Meraki, is this problem going to get fixed anytime soon, or are you just giving your customer's the middle finger on this one?


I've got a ton of new company owned cell phones that I can't roll out due to this, and my management is pissed.


The response I get from support is that Engineering knows about it, but hasn't provided anyone details of any kind (severity, workaround, timeframe for fix, etc.)...


How do you expect us to stay with Meraki when you handle a situation like that...


P.S. - Android 12 came out on October 4, 2021, so you have had a little over 3 months to test this.

Meraki Employee
Meraki Employee

Hello @bleschber and everyone else, thank you for reporting this. Systems Manager does support Android 12, however there is currently an open issue impacting Device Owner enrollments on Android 12. We have already raised the severity of this issue internally and developers are working on a resolution with collaboration from Google.


The work around in the interim is to manually enable Device Owner mode with ADB or use the BYOD Work Profile mode of enrollment. Both of these methods should allow Android 12 enrollments in the meantime. 


I also encourage everyone to please open a support case if you have not done so already. This enables support engineers to attach your case to the internal ticket which helps add additional severity weight to issues, and will allow the support engineers to provide developer updates as they progress.

@MattMorg the ADB method worked perfectly.  My staff is interested in knowing if there is a timetable on getting the root symptom/issue fixed.  Should customers plan on having to use the ADB method for device owner mode for a significant amount of time?  or is a fix something that is anticipated soon?

@bleschber Thank you for confirming using ADB to enable DO mode on Android 12 for enrollment is working as a work around.

Good news: our developers have a fix for this working internally, and we are currently going through some testing/cleanup with it. So this will be fixed for everyone shortly, hopefully within the next week or so. I'll share an update here when it live and ready, and support will be able to provide updates via your support cases as well.

Meraki Employee
Meraki Employee

Just an update for everyone about this issue: it should now be resolve. A new SM app will be downloaded (version 5.7.9) from the new QR code labeled "Android version 7+ (Nougat)" on the SM > Add Devices Page which should work for these Android 12 Device Owner enrollments. Tap the screen 6 times during startup, scan the QR code with Android 12, and you should now be able to enroll without this error. @HiroY @bleschber Thank you for reporting this to support and bringing this up. 

Any reports of Azure authentication failing with this?  It is just spitting out an error when it tries to bring up the sign in prompt.


Development is already investigating this issue. Meraki seems to add a prefix before the tenant ID, that's why MS can't find your tenant.

For now we disabled the option 'Allow multi-user authentication'.

@MattMorg Any idea when this version 5.7.9 will be public available?



Meraki Systems Manager - Apps op Google Play

Version 5.7.8 is still the latest version?

Comes here often

I also faced the same problem, hope the dev team can fix it soon.

New version is still available.
But you will get an old version if you use Samsung Knox Enrollment and have created a profile there which will take the Meraki SM from the link (https://dl.meraki.net/androidsm/AndroidSM.apk) which you can find in:

Android Enrollment - Cisco Meraki


Solution: use Android Zero Touch enrollment, which will download the apk from the Google PlayStore.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.