DEP enrollled IOS, removed from network, unable to re-add, wipe, manage.


DEP enrollled IOS, removed from network, unable to re-add, wipe, manage.

Some how an IOS 11 DEP enrolled iPad pro was removed from a network. I may have done it on mistake. Anyway, the iPad was enrolled using DEP. Its still shows up under DEP (and status shows active, still assigned to the network), but does not show in the client list under the network. When clicking on the client (under DEP) it opens the details and at the top is says that the management profile has been removed from the device. The DEP settings don't allow the management profile to be removed, nor does it allow the iPad to be wiped, nor does it allow the installation of apps or access to the app store. I don't have this particular iPad in my hands, so I tested the same scenario with another iPad. The iPad still shows the Meraki Management device management profile installed. I've tried re-adding using, which just brings up the already active management profile, but does not re-show in the client list in MDM. At this point I have 2 iPads that I cant do anything with except use them in their current state. I've also tried removing the device from DEP and re-adding per instructions, which just puts me back one step marking the device as Assigned instead of Pushed, and showing Client Synchronization not complete in the details. Any suggestions? 

4 Replies 4
Building a reputation

you need to hard reset the iPad in order to enroll it again.



Alright, usually when a DEP device looses the management the device has to be wiped and set up as new or you can restore from a backup from the same device that had the profile on it before it was removed.


I tested your senario, remove the device from the dashboard, go to the DEP section in Meraki and the device was still listed, but it had "Meraki Management Profile Removed". I went to the iPad and went to > entered network ID > entered my AD credentials to enroll > Downloaded & Installed the Profile. This worked for me! The new profile installed freshly over the DEP Profile (and it is still locked). It showed backup in dashboard and restored communication with the device. I know you said you have done this, but give it another shot. You can also try the Meraki MDM app if this method does not work. 


Hope that helps!


Find this helpful? Click the kudos button. Thanks!
New here

Did you ever figure this out? I'm having the same issue.


I believe I managed to wipe the device using iTunes even though I should not have been able to. Its been a while.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.