Android 8.1.0 - Samsung Keyboard not appearing after device restarts

Just browsing

Android 8.1.0 - Samsung Keyboard not appearing after device restarts

Hi all,

For a bit of background I'm trying to enforce a multi-app Kiosk mode on some Samsung A6 Galaxy Tabs (Android 8.1.0, Samsung Experience 9.5). I've built up a simple Kiosk Mode profile with access to two apps explicitly allowed and an empty black-list for Android System apps to allow the Keyboard through. I originally used a white-list with the specific Samsung Keyboard app ( as the only app in the white-list but switched to empty black while troubleshooting. The devices are running with Android Enterprise enrolment and Meraki SM app confirms that SM is the device owner.


What's happening is that when I apply the profile the keyboard will appear when I try to unlock Kiosk mode or enter one of the two apps. However if the device is restarted the keyboard will no longer appear. I suspected initially that the Samsung Keyboard was trying to force open its tutorial/first-run screen so I tried swapping in Gboard by pushing it to the device but it didn't make any difference as I suspect there is no way to force a change to default keyboards from Kiosk mode. I force removed the profile to get it back out of Kiosk mode, swapped the default keyboard in the settings and relaunched Kiosk mode and it resulted in the exact same issue once restarted.


Any help with how this could be solved would be much appreciated.  

6 Replies 6
New here

did you find a solution yet?  I am having the same issue.  After restarting/powering down the tablets, the keyboard doesn't show up. It was working before i powered off/restarted the devices and now i am find that all the tablets i provisioned in kiosk mode are not working as they did before i powered down.   i've tried the same things whitelist (samsung keyboard) /blacklist(empty or using a not important app).  i didn't try the alt keyboard yet but looks like that won't help. did Meraki support offer you a solution ??

Unfortunately no, no help from the crowd at this stage. I ended up getting around the problem by removing the devices from Kiosk mode and stripping all non-essential apps off the device and locking down as many settings as I could without Kiosk mode to sort of emulate a Kiosk-lite setup. It's far from optimal but it does at least get the tablets back out onto the floor and running.

If anyone else has a solution I would be keen to hear it,

thanks for your help ... meraki support wants me to send them the log files from the android tablets.  maybe they can provide some insight on what's going on.  i'll keep you posted.

Meraki Employee
Meraki Employee

Hi @BenMusgrove @brianb 


We have been working on a new version of the Android app which may resolve this issue.  Might you be interested in beta testing this version? If so, please send me a DM with a link to your environment.  I will enable the beta and provide you with further instruction.  



Unfortunately the issues we were having forced our organisation to pivot into another MDM so I won't be much help any more I'm afraid. It's a pity too, Azure is much more opaque about pushing apps and managing profiles so I would have liked to go back to using Meraki. Unfortunately the outstanding issues and cost ended up tipping our management the other way.

I know this is old, but did this ever get resolved? I am seeing this show up occasionally, which has been driving me crazy, but the reboot makes sense. 


The last information I had on this topic from other sources was to update to either Android 9 or 10.  I don't really see that as viable for many situations, so I hope there is still some file that may fix this.  




Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.