Meraki Employee
Meraki Employee


I have an MX64 and MR42. I am struggling to set my Sonos up with this network.


Usually a Sonos is plugged into a home router (EE in this case) via Ethernet cable, it then picks up the wireless connection, you can then unplug it and it will carry on working wirelessly.


In this case I am plugging it into the MX64 to pick up the connection from the MR42 to then work wirelessly, but it doesn't connect. I am putting my MR42 in bridge mode and I only have one VLAN.


Has anyone come across this problem before, if so could you please offer some guidance?

Kind of a big deal

Check to make sure you are allowing local LAN access and not doing any isolation on the Wireless. It's under Wireless --> Firewall




And be sure that the port on the MX you're connecting the SONOS to is an access port in the correct VLAN.


I had the same problem and changing the FW rules dit the trick. Thanks


I have been experiencing the same issues. My Sonos speaker won’t connect to my network. However, I followed these instructions and it wouldn’t connect so I put the network in bridge mode. The Sonos speaker than wirelessly connected the network but then my other devices like my iPhone and MacBook won’t connect. After this I tried changer the network settings back to NAT mode so that my other devices could connect but now the Sonos speaker can’t connect. I am not sure what to do. I am also using an MR42. I haven’t tried wiring the speaker to the MR42 since it only has one ethernet port. Should I get an external ethernet port and try wiring it through there? 

You can use a dedicated SSID for your SONOS devices that is set to Bridge Mode


I can also confirm that changing as @jdsilva said, solved it.

Kind of a big deal

I think it depends on your cell phone whether it can succesfully fetch the WiFi password for your WiFi from it.


On some cell phones it can automagically connect to your WiFi without ever having it connected to your network via wire. For that it connects to an SSID broadcasted by the speaker and sends it the password for your SSID.


If that fails it seems to fall back to the method you described where you have to connect the speaker over wire temporarily. However there again, it depends on the cell phone whether it can fetch the WiFi password or not. For good reason recent cell phones don't allow that these days. So when that fails another wizard again should take over allowing you to enter the PSK of your SSID. Some screenshots of the steps in it below.




If that wizard failed to start, perhaps you can start it manually using the first item in the advanced settings menu (while it's still connected via wire of course):



I hope that helps!

Here to help

Hi , 


My experience with Sonos is: cable or wifi, but do not use both. Not sure what Sonos you have, but older models are prefer the cable, however newer models are prefer the wifi more.

Check L3 / L7 firewall configuration as jdsilva said, might you need to "statically address your Sonos with whitelisting".

Hope that helps!

Kind of a big deal

If you're using the MX as a DHCP server, I've run into problems with Sonos when the DHCP is using the upstream DNS. Or rather - the Sonos speaker magically began working after we statically assigned the DNS, rather than using the upstream DNS function.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.