Snapshot API URL not working

shecool
Conversationalist

Snapshot API URL not working

I'm currently testing the snapshot API for a integration project. When I post to the API, I am getting a URL but the URL is not working. I am receiving an error 502. I can't quite figure out the issue here -- is it an issue on my end or is there something going on with the API?

 

For reference I am using an MV12N. I know there is normally a 5second delay but after waiting I am still receiving an error 502.

3 REPLIES 3
BrechtSchamp
Kind of a big deal

Do you always get that error, or does it sometimes work?

 

If you are willing to share your code I can give it a try on our cameras to see if I have the same issue.

Hi -- thank you for offering to help. 

 

I actually realized it was a network issue, though I am not sure what exactly is being blocked as I don't have administrative rights over this network. To give a bit of background, the camera was connected to an internal lab network at my work. While on my corporate network direct streaming was working, but when I returned home and tried to access the camera feed via dashboard, I got a cloud streaming error. Once I moved the camera to a different network and re-tried the code, and the returned URL worked. 

Ah I see, that explains things :). Good that it's solved.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.