ServiceNow ServiceGraph Connector for Meraki - v1.3 Released

Meraki Employee
Meraki Employee

ServiceNow ServiceGraph Connector for Meraki - v1.3 Released

ServiceGraph Connector for Meraki v1.3 released!

Store Link
Happy New Year!
With the first release of the year, we wanted to improve the overall setup and support experience with the ServiceNow ServiceGraph connector for Meraki.
This should help get your Meraki equipment imported into ServiceNow in no time. If problems do come up, new shortcuts and logs are provided to help resolve common issues.
In addition, this version is now certified for the Tokyo release of ServiceNow. 
Release Notes
  • Improved Guided Setup experience
  • New Administrative and Debugging menus to aid with setup and troubleshooting
  • The import job now supports pre/post scripts to adjust the CMDB sync process
  • Support for enhanced ServiceNow security requirements when receiving Meraki webhooks.
  • Bug fixes, improved error handling as well as compatibility updates for the ServiceNow Tokyo release





An updated menu and dashboard to manage and monitor your Meraki equipment from ServiceNow






Device List shortcuts and custom views enabling quick access to Meraki device details. 








Incident generation allows you to capture Meraki alerts and associate the event with a device such as a wireless access point. 


The process for configuring this feature is best configured using the ServiceNow webhook template, included within the Meraki Dashboard. Read more about configuring this here






New menu containing logs and administrative shortcuts will help to quickly identify errors and access to core app settings. 






Improved Error Logs to help understand common challenges with the integration.


Sometimes something is not quite right with the setup details and it wasn't always clear where the problem was or what some cryptic error message was saying. So, we've improved the overall logging experience by using human readable error messages with explanations as to what may have been wrong. 






Advanced users now have the option to modify the import process.


We have moved the core logic of the app into its own script which is then imported into the scheduled job. This enables administrators to adjust any of the mapping logic before/after the import job is run.



Meraki SGC Script

Screenshot 2023-01-17 at 16.38.50.png




Import script

Screenshot 2023-01-17 at 16.37.30.png



We hope that you find these improvements useful and stay tuned for further enhancements later this year. 










How do you get any support on this connector?  I need someone to give my SNOW Dev instance access to this app.  This needs to be done from the creator of the app. Watch this video.

ServiceNow Store Apps Available on Private Developer Instances - YouTube

We have responded to your question @Chris_XCW, via the initial email you sent. Apologies for the delay.

I am able to see the Meraki application in my Dev instance now, thanks.  However, I am having an issue getting this one dependency installed. I can't find this dependency anywhere. Is it part of another app?





Here is a ServiceNow community thread that looks like it could help


Yes, I found this last week. It worked and I have been testing the connector.  Thanks for following up on this.

Hey Chris - How did you get the com.snc.itom.license dependency installed? I did manage to get the rest of the dependencies including glide one but can't seem to figure out that one to save my life. 

Just browsing

I have installed the app and gone through the setup, but for some reason it appears that I cannot read our organization from within ServiceNow.  When I try to test load 20 records using the SG-Meraki Devices data source no records are returned.  There is no error returned either.  I have also tried accessing the endpoint from my own script within ServiceNow.  When I execute the script it returns a 200, but no organizations (we only have 1) are returned.  I can access that endpoint from SoapUI using the same API key I am using in ServiceNow and our organization record is returned successfully.  Any idea why I would not be able to read our organization from within ServiceNow but can from outside ServiceNow using the same key?

Comes here often

Looking to see when we can install this for our newly upgraded Utah instances?  Is there a timeline when this would be possible?  Or if there are any other ways to install the Tokyo version?

Comes here often

I also waiting on this, need to revisit configuration, but cannot do so, getting incompatible error when attempt to update app

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.