cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Results return when calling API

Highlighted
Getting noticed

Results return when calling API

Hi there,

 

I have been browsing through the forum but don't see my answer yet... Anyway this is my problem... It is not really a problem but a bit annoying when you run scripts with API call over a big network.

 

Using Ubuntu 19.04 

Python 3.75

Visual Code Studio.

 

When i am run a script something like this (SNIP)

 

my_latency_results = dashboard.devices.getNetworkDeviceLossAndLatencyHistory(my_network_id,my_serial,my_dst_ip)

try:
   my_latency = my_latency_results[-1]
   my_avg_latency = my_latency['latencyMs']
   my_start_time = my_latency['startTs']
   my_end_time = my_latency['endTs']
   my_count = 1
except:
   my_count = 0

 

I get this info back whenever i called the meraki API

 

      meraki:     INFO > Connectivity monitoring destinations, getNetworkConnectivityMonitoringDestinations - 200 OK

      meraki:     INFO > Devices, getNetworkDeviceLossAndLatencyHistory - 200 OK

      meraki:     INFO > Devices, getNetworkDevices - 200 OK

      meraki:     INFO > Connectivity monitoring destinations, getNetworkConnectivityMonitoringDestinations - 200 OK

      meraki:     INFO > Devices, getNetworkDeviceLossAndLatencyHistory - 200 OK

      meraki:     INFO > Connectivity monitoring destinations, getNetworkConnectivityMonitoringDestinations - 200 OK

      meraki:     INFO > Devices, getNetworkDeviceLossAndLatencyHistory - 200 OK

      meraki:     INFO > Devices, getNetworkDevices - 200 OK

      meraki:     INFO > Connectivity monitoring destinations, getNetworkConnectivityMonitoringDestinations - 200 OK

      meraki:     INFO > Devices, getNetworkDeviceLossAndLatencyHistory - 200 OK

      meraki:     INFO > Connectivity monitoring destinations, getNetworkConnectivityMonitoringDestinations - 200 OK

      meraki:     INFO > Devices, getNetworkDeviceLossAndLatencyHistory - 200 OK

 

Is there an easy way to suppress this information... When running a script over an organisation network of more than 300 networks, it is hard to see all the relevant information you want to see on your screen

 

Due to this corona outbreak and lock down of the netherlands, i have more time to spent scripting at home 🙂

 

1 REPLY 1
Highlighted
Kind of a big deal

Re: Results return when calling API

You must have logging enabled somewhere.  Turn it off.  Look around the Meraki SDK init.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.