Python API errors

Getting noticed

Python API errors

Hi all,


Still trying to run my first Python SDK API command, bou until now without sueccess. I'm confortable with postman Rest IP, but my focus is to make the shift orgID.PNG to Python.


Please find below the error message I received while trying to run the SDK python script.


Any help is really welcome





1 Accepted Solution
Kind of a big deal

2 Replies 2
Kind of a big deal

This topic and the example code I posted there will probably help you:

For whatever reason, it does not like Version 2 when I run the code. I changed it to run on Version 3 and it worked. 


Using VSC and the code runner you are utilizing. Try running the following Commands to determine what version it is using to execute to script:

import sys


If you are using Code Runner on VSC, you want to add the following to the settings.json file:

"code-runner.executorMap": {
        "python": "<fully qualified path to version 3>"

This will change the default python version for Code Runner to Version 3.



I usually use Atom and didn't have any problems. I installed VSC and tried it with Code Runner and immediately had issues. I had already pointed Atom to use python3, when I used other methods to run it on 2 I got the same error message.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.