cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem with installation on Home / Build / Automation with Dashboard API

Comes here often

Problem with installation on Home / Build / Automation with Dashboard API

1. I am new to Meraki and trying to learn via the tutorials available on Developers.meraki.com.

2. I am on a MacAir and navigated to Home / Build / Automation with Dashboard API

3. The steps listed are below.  The install is failing on step #4 with the error message "

pip3 install --upgrade requests

-bash: pip3: command not found

 

What should I do?

 

thanks

For macOS users:

  1. Install Homebrew first, if not already present, in terminal:
    ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
  2. Install Python 3.6
    brew install pyenv
  3. Install PyEnv
    pyenv install 3.6.5
  4. Install the requests module
    pip3 install --upgrade requests
  5. Install Dashboard API module
    pip3 install --upgrade meraki
  6. To make sure your installation is successful, launch Python
    python3
  7. Now you should see the >>> input, and you can interact with Meraki with a request for the list of organizations
    from meraki import meraki
    meraki.myorgaccess('e24759c28edd1d97715a6ba9ea8bc679c5d2706b')
  8. You should see similar results being returned:
    {'id': 578149602163687854, 'name': 'Public API Lab'}
10 REPLIES 10
Kind of a big deal

Re: Problem with installation on Home / Build / Automation with Dashboard API

Pip3 is part of the python install. Was that succesful? What is the output for:

 

python --version

Perhaps try restarting the terminal or the laptop as a whole.

Comes here often

Re: Problem with installation on Home / Build / Automation with Dashboard API

Thank you for the quick response.

 

1. Yes command #3 i.e. pyenv install 3.6.5 completed okay

2. Tried restarting laptop and re-running command #4 i.e. "pip3 install" , got the same error "

pip3 install

-bash: pip3: command not found"

3. Tried reinstalling 3.6.5 and rerunning #4 - same error.

 

pyenv install 3.6.5

pyenv: /Users/rohithans/.pyenv/versions/3.6.5 already exists

continue with installation? (y/N) y

python-build: use openssl from homebrew

python-build: use readline from homebrew

Downloading Python-3.6.5.tar.xz...

-> https://www.python.org/ftp/python/3.6.5/Python-3.6.5.tar.xz

Installing Python-3.6.5...

python-build: use readline from homebrew

Installed Python-3.6.5 to .....

 

Not sure what to do next.  Am also trying on a Win10 environment.

 

thanks

 

Kind of a big deal

Re: Problem with installation on Home / Build / Automation with Dashboard API

What about "python --version"?

Comes here often

Re: Problem with installation on Home / Build / Automation with Dashboard API

1. Response to entering "python --version" was Python 2.7.10

2. Tried the suggested installation for Win10 - worked like a charm.  MacOS still an issue..

 

thanks

Kind of a big deal

Re: Problem with installation on Home / Build / Automation with Dashboard API

Are you using Anaconda or Miniconda on the mac? Try the one you are not using. I expect serpentine labyrinths when playing the snake charmer these days.

https://conda.io/docs/user-guide/install/macos.html 

Robin St.Clair | Principal, Caithness Analytics | @uberseehandel
Kind of a big deal

Re: Problem with installation on Home / Build / Automation with Dashboard API

I have a feeling it's using a pre-installed version of python on your Mac.

 

Try issuing the following command:

pyenv global 3.6.5

Comes here often

Re: Problem with installation on Home / Build / Automation with Dashboard API

1. Yes it is.  Reading up on the MacOS, python 2.7 is bundled with MacOS and it doesn't show up under Applications, and there is a caution against removing it.  Just upgraded the OS to the latest version Mojave 10.14, but the default version of python remained unchanged at 2.7.10.

 

2. "pyenv global 3.6.5" did not result in any confirmatory message or any error message.  However python --version still displays 2.7.10 and "pip3 install --upgrade requests" still errors with "-bash: pip3: command not found"

 

thanks

 

 

 

Kind of a big deal

Re: Problem with installation on Home / Build / Automation with Dashboard API

Yeah indeed, removing it would probably be a bad idea.

 

Unfortunately I haven't got a mac myself, so I'm a bit in the dark here. I'd guess something went wrong with one of the steps. Because as far as I understood from the docs the pyenv global command should make the mac use the version you specify as default from then on. So the output of the python --version command surprises me, it shouldn't be outputting python 2.7.1 anymore.

 

What's the output of:

pyenv versions

 

 

New here

Re: Problem with installation on Home / Build / Automation with Dashboard API

I have the same issue on my MAC

 

python --version
Python 2.7.10

 

pyenv versions
* system (set by /Users/userid/.pyenv/version)
3.6.5

Kind of a big deal

Re: Problem with installation on Home / Build / Automation with Dashboard API

So your issue is also with step 4 of the process? Same error?

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.