Showing results for 
Show  only  | Search instead for 
Did you mean: 

Meraki API 404 error

New here

Meraki API 404 error

Hi guys,


I worked two years ago with the Meraki API in postman.


Some days ago i downloaded the new postman Meraki library.


But when I do the request with the old (the old postman Meraki library) one it works!!


But when I do the same org requets (GET) with the new library that btw has more methods right now.


I am getting an 404 error...



here the examples:


With the new one:




With the old one:




I saw that in the new API the URL change from "dashboard.meraki" to "api.meraki"


So I changed manually the URL but didn't work.....


I also see that in the documentation the only header they send is "Accept : */*" I did not see the API key field


So I tried just with the Accept .... Did't work


I tried with both (API-Key & Accept )... didm't work


I just with the API key .... didn't work


So I can't find where is the issue..... why with the old postman library is working and not with the new one ?


regards, Ulises.


Kind of a big deal

Re: Meraki API 404 error

Please change the picture ASAP and hide the view of your API key.

Kind of a big deal

Re: Meraki API 404 error

This is the Postman getting started guide.  Unfortunately, everything you have done looks correct to me. 


Double check your API key doesn't have a leading or trailing space, or something else unusual about it.

Here to help

Re: Meraki API 404 error

Hi Ulix,

I had the same problem, found a workaround by choosing "No Auth", specifying bulk edit in Headers to insert

X-Cisco-Meraki-API-Key value


Content-Type : application/json 


Also, setting variables in collection didn't work for me, but if i set them manually inside the Params tab, these worked...

Could it be that the Postman implementation sometimes doesn't work?


Problem here is, if we can't pass variables from collection or from environment, then the automation doesn't really happen properly.





Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.