API Call to /networks/[networkid]/firmwareUpgrades fails with "Invalid upgrade version specified"

etamminga
Conversationalist

API Call to /networks/[networkid]/firmwareUpgrades fails with "Invalid upgrade version specified"

Hi,

 

I have an MX sitting on 18.107.2 wanting to upgrade to 18.107.8.

 

A GET to  /networks/[networkid]/firmwareUpgrades shows:

"availableVersions": [
{
"id": "2509",
"firmware": "wired-18-1-07",
"releaseType": "stable",
"releaseDate": "2023-05-23T18:08:43Z",
"shortName": "MX 18.107.2"
},
{
"id": "2789",
"firmware": "wired-18-1-07",
"releaseType": "stable",
"releaseDate": "2024-01-26T00:36:30Z",
"shortName": "MX 18.107.8"
},
{
"id": "2850",
"firmware": "wired-18-2-08",
"releaseType": "candidate",
"releaseDate": "2024-02-13T15:30:24Z",
"shortName": "MX 18.208"
}

]

 

A POST to /networks/[networkid]/firmwareUpgrades  with:

 

...
"products": {
"appliance": {
"nextUpgrade": {
"time": "2024-02-20T11:59:00Z",
"toVersion": {
"id": "2789"
}
},
"participateInNextBetaRelease": false
},
...

 

fails with message "Invalid upgrade version specified".

What causes this issue? Is there a DB error @Meraki by having 2 firmwares with the same name but different id's?

 

PS. I have like 200+ sites to upgrade soon, need help 🙂

Regards,
Erik

1 Reply 1
DAlleman
Meraki Employee
Meraki Employee

@etamminga We have a known issue affecting patch version upgrades specifically for MX node groups when called via the API. This is not impacting other nodes (MS, MR, etc.) or full version upgrades like MX18.208.

In your example above, if you upgrade to "id": "2850" for MX18.208, the call will be successful.

Please open a support case with us so we can track this issue and keep you updated with any developments.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.