Pushing custom .apk not on google play store to Zebra TC520k

Here to help

Pushing custom .apk not on google play store to Zebra TC520k

So i have systems manager setup working perfectly for all my apple devices. Rolling out android devices now. I have a custom apk from a vendor and i have installed it manually and works fine. When i try to push it through systems manager i see it in systems manager but says failed to install. I am assuming the problem is i do not have the correct indenter is there anyway i can find out the correct identifier for the app. Also another problem i having is meraki is not reproting the correct location at all even though it has access for location in android settings set to always. 

10 Replies 10
Kind of a big deal
Kind of a big deal

The identifier is the companies domain and app name in reverse.  So something like:



The developer of the custom APK should be able to give you the ID.

Thanks for the reply that worked i was able to get it from the failed install of the app at the end and used that and it worked thanks again so much. Also another question any idea why location services are completely off on this device in meraki. 

Are you managing it in Device Owner mode?

yes it is 

i enrolled when the device started up by putting that afwmearki as the google account and then downloaded systems manager and installed it. all apps are pushing and restrictions are carrying over no problem just the location is completely off. 

Location services should work then.  Is location services enabled in the device settings (perhaps that manufacturer defaults to having it off)?


Perhaps it can't get a GPS fix inside?

In the meraki sm app it shows location services with a checkbox. This device is not running on a lte signal its running off wifi. I also use to get this with ios devices it seems its not the greatest for this in that regard. 

Kind of a big deal

Check that the devices actually have GPS positioning capabilities. I know for instance that the Apple iPads which only have the Wifi chipset (i.e. no LTE) didn't have the GPS capability either as it was embedded as part of the LTE chipset (not sure if that's still the case). They used a kind of psuedo GPS based on the Wifi networks they can see, so there are times it is inaccurate - a colleague of mine found this out the hard way when he attempted to use a Wifi iPad for navigation over open water...

Here to help

The GPS issue is likely the same one I've had a ticket logged for since Aug 2019, so I expect it will never be fixed (though they have tried a few times this year with SM app updates).  The workaround on our TC25s was to go into Settings -> Security & Location -> Location Mode and change it to High Accuracy.



Sorry!  I read my notes wrong initially, and put the wrong mode at first.  What you want is High Accuracy mode, Device Only mode is the default mode and that's where the problem is.  Meraki MDM doesn't seem to have a way to enable High Accuracy mode automatically, and the SM app throws an exception behind the scenes when the phone is in Device Only.  From the reading I've done on accessing GPS data through Android, it should be trivially easy for Meraki to detect the current location mode and correctly request the data depending on the mode, but so far the new versions I've tested didn't fix it.


Also, you can tell it's working correctly if you get the "location pin" showing up in the status bar when you run the Meraki SM app.

I wen to  Settings -> Security & Location -> Location Mode and the only option there is under mode is battery saving it wont let me click it or change it anything else which is odd see attachedzebra.jpg

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.