How to Restrict Accessibility or Guided Access in Meraki?


How to Restrict Accessibility or Guided Access in Meraki?

I've got several iPads in classrooms and need a way to shut off/restrict Accessibility or Guided Access in Meraki. I can't see where I can apply a restriction or policy for it. I have students using it to apply a passcode to lock the device to one app. While I can remove the passcode using Meraki its a pain and it takes some time to complete. I'd rather not give my "clients" access to the option.



9 Replies 9
A model citizen

Are these Ipads enrolled DEP ?


This falls under a Profile  and creating Restrictions 


Those Ipads would need Tags and the Profile be assigned to the Following Tags 

Kind of a big deal
Kind of a big deal

I could be wrong, but I don't think Apple allows MDMs to control the accessibilty options.

Passcode can be configured not to change  and accounts ,,  Screen time can prevent a few things also 

Our Ipads have a Passcode to unlock and then for Screentime a  Passcode only known by IT


You can also set a PassCode Policy Via Meraki MDM Profile settings 

When you say: "You can also set a PassCode Policy Via Meraki MDM Profile settings " would this apply to the Guided Access Passcode?

A model citizen


Here to help

After pulling my hair and searching everywhere , I solved it by disabling the guided access and enable it.

Here to help

I can tell you what worked for me, what i did was this worked on your iPhone, there are some steps you can take to troubleshoot and potentially fix the issue. Here's a guide to help you:-

1. Ensure Guided Access is Enabled:-

  -Go to Settings on your iPhone.
  -Scroll down and tap on "Accessibility."
  -Under the "General" section, find and tap on "Guided Access."
  -Make sure the switch at the top is turned on.
2. Set Passcode for Guided Access:-

  -In the Guided Access settings, make sure you have set a passcode. If you haven't set one, Guided Access may not     work.

3. Reset Guided Access Settings:-

  -If you have previously configured Guided Access settings, try resetting them:
  -Go to Settings > Accessibility > Guided Access.
  -Tap on "Passcode Settings."
  -Choose "Set Guided Access Passcode."
  -Enter your Apple ID password when prompted.
  -Set a new passcode or re-enter the existing one.
4. Check Accessibility Settings:-

  -Make sure there are no conflicting settings in the Accessibility section that might interfere with Guided Access.             Check other settings like Display & Text Size, Motion, Touch, etc.
5. Toggle Guided Access Off and On:-

  -Turn Guided Access off and then on again:

  -Go to Settings > Accessibility > Guided Access, & Toggle the switch off and on.
6. Reboot Your iPhone/iPads:-

  -Sometimes, a simple reboot can resolve issues. Restart your iPhone and check if Guided Access works afterward.

Follow for more details instruction below.


Get notified when there are additional replies to this discussion.