Dashboard advritical update required - device says up to date

Hallmark73
New here

Dashboard advritical update required - device says up to date

Hi All, 

 

So when i view my Orgs Firmware status it tells me i have a critical update required to be applied, however when i go to the device it says the firmware is up to date. Does anyone know why its presented like this?  

 

For info device is currently running 18.107.5.  My options are 18.107.8(latest patch) and 18.208 (stable release candidate)

 

Appreciate any info on it.

 

thanks 🙂

10 Replies 10
alemabrahao
Kind of a big deal
Kind of a big deal

Do you have any template in your organization.?

 

Can you show the firmware status?

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

Hi Alemabraho, 

 

this is from the device:

Hallmark73_0-1709212565771.png

 

There is a template for this network, the device is listed under the template on the dashboard:

Hallmark73_1-1709212772352.jpeg

 

This is a sample for all similar devices:

Hallmark73_2-1709212952651.png

 

Got me a bit stumped!

What model is your MX? I'm looking here on my dashboard and the latest stable version available is 18.107.2.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

Hi Alemabrahao, 

 

They are a mixture of MX-100 and MX84.

 

 

Ok, anyway this version is not stable, so I suggest you leave it at the version recommended by Meraki.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
jimmyt234
Getting noticed

The firmware status for 18.107.x seems broken to me, as if you're running 18.107.2 it will say you're good whereas if you're running anything from .3 - .7 it will say warning/critical because there is a .8 patch available.

Hi Jimmy, 

 

yeah, thinking that rolling back to .2 might clear it.

 

thanks

I would go up to .8, not down to .2

rhbirkelund
Kind of a big deal

When you go to the device, and it says Firmware Up-to-Date, this simply means that the device is running the configured firmware for your network. This is as it should be. If you have configured, e.g. MX18.107.8 and it's running MX18.107.5, then the device would complain with "Not Up-to-Date", and would attempt to upgrade to .8. Once this happens the device would most likely be "Up-to-Date" again.

 

Now, if you go to Firmware Upgrade on your Org-Wide menu, and the firmware says Critical, this means the the firmware has reached its End-of-Support date, and is no longer supported, meaning that there may be security vulnerabilities or severe defects, that may need to be addressed.

If you are running a firmware that is Critical, it's recommended that you move away from that firmware version, to either a Stable or Beta release.

There's more info about it here.

LinkedIn ::: https://blog.rhbirkelund.dk/

Like what you see? - Give a Kudo ## Did it answer your question? - Mark it as a Solution 🙂

All code examples are provided as is. Responsibility for Code execution lies solely your own.
PhilipDAth
Kind of a big deal
Kind of a big deal

Going sideways, I would upgrade to 18.107.8.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.