Bonjour forwarding

New here

Bonjour forwarding

I am trying to get Bonjour forwarding to work with Apple TV's. Currently using Layer 3 roaming.


What would be the best way to disable Bonjour forwarding for Apple TV's but allow it for Bonjour printers?


Basically I want the same features as NAT mode (Only showing Apple TV's connected to the same AP) but still allow clients to view every Bonjour printer. The print server is broadcasting the printers so could I just whitelist that IP?

3 Replies 3
Kind of a big deal
Kind of a big deal

I was able to follow that but I still don't know how to allow all printers but only show nearby airplay devices.

Hi @averythomas


The only way I can think of at the moment to allow this would be to have a different vLan for each AP SSID/Apple TV setup. Then you could enable the forwarding for AirPrint and not set forwarding for AirPlay. As long as your clients on that AP/SSID are on the same vLan as your Apple TV, it should show available (as long as firewall rules allow it) and you can see all available AirPrint printers on the vLan that is forwarded.  

Found this helpful? Give me some Kudos! (click on the little up-arrow below) and If my reply solved your issue, please mark it as a solution 🙂
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.