cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Per ssid vlan not working.

Here to help

Per ssid vlan not working.

We are facing the below mentioned issue with one of our meraki customer, need your help ASAP.
I have created one SSID and Tagged multiple VLANs in my MR53 AP.
But client is not getting the IP address as Per VLAN.

Description:
One VLAN at a time works well. But i need to have multiple VLANs tagged for one SSID so when users from different VLAN tries to connect and they should to get the IP address as per VLAN assigned to them.

Please help us ASAP.

Thanks and Regards,
Upendra VN

8 REPLIES 8
Kind of a big deal

Re: Per ssid vlan not working.

How are you doing this?  Group policy?  RADIUS?

Here to help

Re: Per ssid vlan not working.

Thanks for the response...:)

 

 

I am configuring  through Radius Server...

Here to help

Re: Per ssid vlan not working.

I am configuring through RADIUS server.

 

Actually the problem occurs when i add multiple VLANs.
For example: in the VLAN Tagging Option i have added multiple VLANs i.e VLAN 502(for Executives), VLAN 503(for Students) and All other APs 504( for IT).
So now if a Executive user tries to connect to the SSID, he should receive a IP from VLAN 502( for Executive) but the user is getting the IP from VLAN 504(for IT).

If any IT user tries to connect to the same SSID, he is receiving the IP from VLAN 504(for IT) which is correct. 🙂

Note: any user from Executives or Students tries to connect to the SSID they are getting the IP from IT vlan i.e VLAN 504.

Hope this example Gives you a clear Explanation. 

Kind of a big deal

Re: Per ssid vlan not working.

It is only valid to return a single VLAN per user.  Is this what your RADIUS server is doing?

 

Check your RADIUS policy to make sure it is matching the policy you think it should be.

Kind of a big deal

Re: Per ssid vlan not working.

To clarify, the RADIUS server is returning the VLAN number to drop the user into, or is returning a Group Policy to apply to a user which contains the VLAN?

Here to help

Re: Per ssid vlan not working.

Ok. thank you.
Here to help

Re: Per ssid vlan not working.

Sir, Actually there are few existing Non Cisco APs functioning properly with radius. so i want to showcase the same with meraki.
so what additional changes i need to check in meraki AP.
Here to help

Re: Per ssid vlan not working.

Hi @Upendra,

 

Maybe this article can help you :

 

Tagging Client VLANs with RADIUS Attributes

 

Be sure to activate radius override.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.