Need Help with my new Z1

New here

Need Help with my new Z1

I just started using Z1 router. I have internet subscription with my internet provider with speed up to 75 Mbps.
First time setting it up, I was able to find a wireless network named "Meraki Setup" across my laptop and cellphone and connect into it without having to enter the security WEP password and getting a wireless connection speed of 50 Mbps and above. See below screenshot:
Inline image 2
After I set up the security wireless network name "drunkenwizard" and WEP password via Dashboard (for SSID 1), the "Meraki Setup" network disappear and now I only getting a wireless speed of only 19 - 21 Mbps. and only can get 50 Mbps via wired connection directly so I am really disappointed with this (see picture below)


1. Why did this happen?
2. How to reset and back using the "Meraki Setup" wireless network so I can get a wireless connection speed of 50 Mbps?
Please help! I want to get the wireless speed of 50 Mbps connection that I was able to get when first time turning on my Z1 modem and connected to "Meraki Setup" network
Thank you!
Head in the Cloud

The "Meraki Setup" SSID is primarily used for initial setup of your Z1/Meraki device. Once configuring a new wireless network within the dashboard this overrides the "Meraki Setup" network.


Do you have any traffic shaping rules setup which could limit the speeds that you are getting? (Security>Traffic shaping within dashboard)?


Are you running advanced security on the Z1 with Threat protection and content filtering or just using the Enterprise license?

Eliot F | Simplifying IT with Cloud Solutions
Found this helpful? Give me some Kudos! (click on the little up-arrow below)

You can't run Advanced Security on a Z1 or Z3. You can only get the enterprise licence.
Kind of a big deal
Kind of a big deal

If you physically plug in with a cable what speed do you get?
Getting noticed

Hi  Joykid


reply  you 1. 2 iseeus,  if you want this “Meraki Setup ”wireless SSID again, I think you can reset you Z1 devices, Whatever, i think ,  Now about the Meraki Setup SSID already miss, so if you not way show it ,  please reset the Z1,   then set again the wireless SSID, 

this configure not have via cloud sync to Z1 devices, so cannot show the signal,  This is just speculation。


3. if you reset the Z1 drivces, when the Z1 restart, you able see the Meraki setup SSID, about Z1 devices reset  please see the link .


I hope helpful you ,

Meraki Employee
Meraki Employee

Did not see your screenshots come through on the post, but the first problem may be that you're using WEP encryption.  Try using WPA2 PSK.  The high throughput and very high throughput (HT and VHT) data rates are no longer used if WEP is enabled as per Wi-Fi Alliance guidelines.  The support for WEP is still there, but it'll likely only be supported at the legacy data rates, up to 54 Mbps.  All 802.11n and 802.11ac shouldn't be using the HT/VHT data rates when WEP is used, and due to the nature of wifi and CSMA/CA operations, you're not going to get 54 Mbps when connecting at the 54 Mbps rate, but perhaps more like anywhere from 50% to 60% of that, which is about what you were seeing. 


If you did still want to "wipe" the configuration and start over, it's probably easiest to remove the Z1 from the Dashboard network where it currently lives, delete the network, create a new network for the Z1, add the Z1 to that new network and paperclip reset the Z1 and it'll come back up in the new network with all the default configuration. 


Kind of a big deal

I'll second what @MerakiDave said re: WEP. You can't use WEP (there is zero reason to be using it anymore) with modern wireless data rates. 

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.