Getting low connectivity MR45 Meraki

New here

Getting low connectivity MR45 Meraki

Just deployed MR 45s and users are getting low connectivity around 1MB...What can I do to adjust this??


Thank you



Meraki Employee

There are a good few things that could be affecting bandwidth, but to help some more info will be needed.


Number of MR45's deployed at the site

Number of clients connected to each AP

Number of SSID's in use

Upstream devices (Switch / CPE)

WAN connectivity type and bandwidth




Also worth looking at your MR firewall & Traffic shaping page to make sure there are no rules limiting bandwidth, as well as checking your minimum bitrate and cell size.


Thank you David....Here is some info:


Number of MR45's deployed at the site:20

Number of clients connected to each AP..very few Covid has us down to maybe 6 in a 200 person office

Number of SSID's in use: 2

Upstream devices (Switch / CPE) Cisco 9300 switch 

WAN connectivity type and bandwidth....MPLS 400MB


FW and Traffic Bandwidth set to unlimited


Thank you

Are there any restrictions on the upstream CPE / Firewall?


You can do a packet capture from going to Network Wide > Packet capture


Another thing to check is the performance of the AP's


(if you upgrade to MR27.5 -  Meraki Health will show a performance tab)

Mainly to verify if it is the AP or the Client that is restrictive. 


Also please feel free to contact Meraki support as they will be able to troubleshoot with you further.


The general Support number is +1 (415) 937-6671 



But by far the best way is on Dashboard. Help > Get help > Still need help?



Are there any restrictions on the upstream CPE / Firewall?...None


You can do a packet capture from going to Network Wide > Packet capture...I will try that


Another thing to check is the performance of the AP's


(if you upgrade to MR27.5 -  Meraki Health will show a performance tab)

Mainly to verify if it is the AP or the Client that is restrictive. 


Upgraded to 27.5 but had to fall back to 26 because of an issue with vers.27


Thank you

Kind of a big deal

Start by looking at Wireless Health, does it have anything interesting to say?


Try disabling 2.4Ghz if you have it on and can.  2.4Ghz has poor performance on the whole compared to the 5Ghz spectrum.

Kind of a big deal
Kind of a big deal

@Dennb10 what was the issue with 27.5, 27 is way better than 26 on the MRx5 range.  One thing to check is are the devices Windows 10 laptops with Intel WiFi5 chipsets?  If so are they on battery power?

@cmr, we have 2 MR45's and are having issues with Dell laptops with Windows 10 and Intel wireless NIC's whenever they are on battery.  Plugged into power they are fine.  Seems to be some issue with the wireless card not getting enough power when on battery.  We are on firmware 27.5 also.

Kind of a big deal
Kind of a big deal

@TechBusAnalyst are they WiFi 5 chipsets?  If so the easiest fix is to go to the properties of the adapter and change the power saving setting to max performance.  It doesn't have a major reduction on the battery life in my experience and 'fixes' the issue.  The other option is to change out the adapters for AX200 ones, that is the option I followed for an XPS13 I have and the replacement card was $17.

Kind of a big deal

>we have 2 MR45's and are having issues with Dell laptops with Windows 10 and Intel wireless NIC's whenever they are on battery.


I have seen this exact issue.  What happens is the Dell notebook sends the frame with the PWR MGMT bit in the frame, which asks the access point to start buffering the frames until the notebook sends another request to get the frames.

Users experience this as low throughput and high latency.


This is not a Meraki issue.

Thanks for the reply @PhilipDAth.  It does kind of seem like it's a laptop issue, but why does it work fine on another Meraki AP and also on other brands such as ASUS that I have tested on?  


It's been kind of a puzzling scenario with this.  And if Windows is updated to 2004, there isn't even an option to change the wifi adapter performance settings.  Which, gets onto a whole other topic on why Microsoft would remove that. 😒  😉

Kind of a big deal
Kind of a big deal

It is a Meraki issue as no other APs seem to suffer.  I'd wager it is the chipsets used in the MR45 and MR55 as I experienced the same on the MR55 but not on earlier 26.x firmwares.  It doesn't affect the Meraki WiFi APs either.  It might be that the chipset is working closer to standard than others but either way it isn't useful behaviour...

Kind of a big deal

>It is a Meraki issue as no other APs seem to suffer.


My bet - other APs are not respecting the PWR MGT bit in the frame.


In a Wireshark capture use the following filter to identify frames your NIC has requested packet buffering for.



This is what it looks like in Wireshark.


Kind of a big deal
Kind of a big deal

@TechBusAnalyst are you saying that this option is not visible:




If so then that is just plain stupid!

@cmr, Yep, they are gone in Build 2004.  We've even looked at adding a registry key to make them come back and it doesn't help.  It appears Microsoft has removed those options.  It seems they have removed other options as well.




Kind of a big deal
Kind of a big deal

@TechBusAnalyst if you run powercfg /query from an elevated command prompt do you see the wireless section:




If so you could change the DC value using powercfg /SETDCVALUEINDEX [Setting GUID] [Setting Index] where 000 is the Index used to disable power saving.

@cmr , I tried updating that with the command, but it won't work since that Registry entry isn't there either.  


It seems Windows has completely wiped it out.  I'm thinking this is going to cause a problem for quite a few people and Microsoft will have to put that option back in place, but we'll see.  Thanks again for the help with looking at this!  🙂

Kind of a big deal
Kind of a big deal

Hi @TechBusAnalyst I "upgraded" my Dell XPS13 that used to have the same issues as you, but now has an AX200 card inside to Windows 10 2004 and I still have the wireless power settings...  I am running the latest Intel drivers ( released in September, might that have an impact?






Hi @cmr, here are my settings.  I've installed the latest drivers for this card according to Intel.  One thing to note, I setup an MR33 AP in the office today and while I'm connected to that AP, my connection is just fine.  It's also been better when I go over near the MR45 and connect to that AP.  I was reading on Meraki's website and it looks like the MR33 is not compatible with Wi-Fi 6.  When you introduce a non Wi-Fi 6 AP into the environment it disables certain features on the AP's.  I wonder if this has something to do with it?  


Here's the link:





Just one more update on this, I've tested a few times today and things have been way better since I have installed the MR33.  Even when connected to our MR45's it's been good.  Any thoughts?

Thanks for the reply @cmr, they are Intel AC8265 cards.  We actually did find that changing the max performance setting does help, but if you have updated your Windows 10 version to 2004, that option has been removed.  So, unfortunately, that isn't an option for those devices.  They can still plug into power and it'll work though.


The odd thing is, if I connect to an MR33 at a different location, the performance is just fine.  Seems like it's just these MR45's that are having the issue.

Head in the Cloud

Hello, I opened a case for this problem.


It´s only on our MR45 (not on MR42, MR42E, MR52, MR32 ...)


It´s only on some Dell Notebook models and on Microsoft Tablets (not with Apple Notebooks f.e.)


The problem occures only when the devices are running on battery.

If you plug in the power supply the problem disappears immediately.


If you change the Win10 power-saving for the Wireless adapter from "normal" to "high..." then it works!


Dear Meraki stuff, do a update for this accespoints, and tell the service that this problem exists, they don´t believe me!

Kind of a big deal
Kind of a big deal

@redsector If it helps I opened case 05245616 at the beginning of June about this when 27.1 was released as it also affects the MR55 for sure with Dell 802.11ac adapters.  Unfortunately as I didn't have a promiscous wireless adapter (Mac or similar) available during lockdown the case was closed as support wouldn't progress without a wireless stream data capture.

I also have a case opened for this and have update them with all I have test and have pointed them to this discussion for more review.


I didn't have a Mac to do a data capture either.  I'm hoping they can figure this out on their end and correct the issue.



I found out:


All devices running with Win 10 (1909)


Dell Latitude E7400 with Intel Wireless-AC 9560 is working well

Dell Latitude E7450 with Intel Dual Band Wireless-AC 7265 is working well

Dell Latitude E7490 with Intel Dual Band Wireless-AC 8265 is not working well


This information I sent to the Meraki case

I worked with Meraki support on this issue a bit more and they showed me how to disabled 802.11ax on the AP's.  


To disable 802.11ax, navigate to Wireless → Radio Settings → RF Profiles → Basic Indoor Profile → 802.11ax.


I've disabled this now and will do some testing to see if that is the fix.  Will post my results!

Yes, shure.

But I don´t buy AX antennas to switch off AX.

News from Meraki support:


So we are aware of some issues on with the Wireless-AC 8260's you're running the 8265's but I believe these are extremely similar to each other. I believe this issue is related to the beamforming (documented below).

With your permission, I'd like to perform a backend change to disable the beamforming on the MR45 for now. If this works this would atleast get things running for the time being whilst a fix is implemented.

Could I ask which SSID we have been testing on so far? This backend change is made on a per SSID basis so we could test this on 1 SSID for now. This change would only take effect on the MR45.

I do not expect disruption to the clients on the MR45 at this time but its also possible they could experience temporary issues or a disconnection when this backend change is made.


Kind of a big deal
Kind of a big deal

@redsector have they applied the change and if so,  any improvement?  I still have one 8260 chipset laptop that would possibly benefit as I cannot change the power settings due to forgetting the admin password 🤦‍♂️

Head in the Cloud

Meraki support did a change as described below. Now it´s working as expected!

I have tested some more now with the 802.11ax setting disabled for both the 2.4GHz and the 5GHz networks and the performance isn't any better.  I've tested a bit more with connecting to the MR45 AP's and the MR33 AP and it's definitely better on the MR33.  The MR45's are still having ping drops and high latency.


I will look over that beamforming article.  Is that a setting Meraki support has to change?

same problem with external power supply?


Meraki put an modified firmware on our MR45:


"So, I need to move just this MR45 onto a different firmware for now, this will mean this will allow everything to keep working even if your MR is rebooted. Again this is only temporary whilst the entire issue is looked into on our side.

Please note the firmware change will involve a short amount of downtime as the device reboots 2-3minutes is likely.

If this is also agreeable I will make this change from my end?"


It´s working now.


To remember:

The issue occures (only?) on Wireless-AC 8260 and 8265 wireless hardware

The issue occures only when the notebook or tablet is running on battery, no issue with an external power supply

The issue occures only when the power saving of the WiFi hardware is set to standard (Win10), not when you change it to high power consumption



In the End: you can´t put blame on Meraki. I think it´s an Intel issue.

Here are the news:


I wrote to Meraki helpdesk after an test-update on one of our MR45:


"Great, it´s working now.

But: you reduced the functionality.
Isn´t it better to complain at Microsoft or Intel to provide a proper driver for the wireless-devices?"


this is the answer:

Looks like Intel has just released an updated driver on 10/20/20.  I'm going to install it and see if it helps.  Will post an update after I test.

Hi All,


I have an update again.  The new driver didn't work, but I did talk with another Meraki support rep and he knew exactly what I was taking about.  He said he experience this last week and has escalated to their development team.  


In the meantime, he gave me a workaround that works for Windows 10 v2004 as well.  In Device Manager, go to the properties of the network card and to the Advanced tab.  Under the MIMO Power Save Mode, change the value to No SMPS.  I tried this and it works great.  Hope this helps until they get a permanent fix!




Head in the Cloud

Hello, I got news: support told me today that the issue is resolved with firmware MR27.6



Hi @redsector , I got an update on my ticket with Meraki as well.  I implemented the firmware update last night and will do some testing with it to see how it works.  Hopefully it will be good now!

I did some testing on Friday and the new firmware seems to have resolved the issue.  I didn't experience any packet loss and had a good connection.  Hoping this stays working as more of our users connect and use the Wi-Fi.  It's also really nice that Meraki followed up on this ticket with me after having the ticket open so long.  

New here

Hi... MR45 and MR55 AP's are infamous for terrible showing and steadiness. And furthermore for being a disappointment since dispatch. Working intimately with Cisco we recommend each affiliate and client to move over to MR46 and MR56.

Kind of a big deal
Kind of a big deal

@IsacVries are you still having issues with 27.6, I have both MR55 and MR56 and the MR55 has finally come good of late.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.