ChromeCast - SmartCast does not work with MR33 with devices on same vlan and switch


ChromeCast - SmartCast does not work with MR33 with devices on same vlan and switch

I have a MR33 with code version 25.12 connected to a Zyxel managed switch and a MX64 firewall as the default gateway (DHCP server and DNS proxy as well).  I have a Vizio Smart TV that I had used with the same switch and a Ubiquiti AC Pro Access point.  


ChromeCast works fine with the Ubiquiti AP, but my Samsung S7 phone does not even see the TV as an Casting option when using the Meraki AP.  


Both APs are configured with the same SSID and PSK, and work on the same switch port in the Zyxel switch.  Only VLAN 1 is configured on the switchports, as I do not have another SSID configured on either Access Point.


The SSID isconfigured in bridge mode.   


The Smart TV is connected to the switch via ethernet cable with the wireless disabled.


I have a Co-worker who is having the same ChromeCast issue with their MR33 installed at their home as well.   


The company we work for has started selling the Meraki line to our small business customers, and so far no one has needed to do Chromecast at the sites we have installed them.  We installed some in our homes so that we could get more experience with troubleshooting them if needed.  





Kind of a big deal

I use Chromecast at several sites with MR33's - and they just work.  I haven't had to do anything special.


An issue I have run into before is when using DHCP don't give out domain names ending in ".local" as this hurts mDNS, which is used by lots of devices including ChromeCast.  If you are not giving out a domain name via DHCP then you wont have any issues.


I usually configure a minimum bit rate of 12Mb/s.  Some devices don't work well with higher minimum bit rates.

New here

This is what I did to make it work:


1. Use Bridge instead of NAT: Wireless --> SSIDs --> edit settings







2. In Wireless --> Firewall & traffic shaping --> Block IPs and ports --> Layer 3 firewall rules, Changed Deny to Allow:





thank you - I tried many other supposed 'fixes' for this - but your suggestion was the one that worked.  


Much appreciated. 



Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.