cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Apple FaceTime poor connection

Highlighted
Here to help

Apple FaceTime poor connection

Hi all.  I've concluded through testing that the Meraki platform, by default, does not seem to handle Facetime well at all.  I have not tested with other video conferencing apps.  

 

I've got an MX67, an MS120, and a pair of MR42's in my house (overkill? nonsense!).  For many months I've put the blame on friends/family thinking their WiFi is the problem, since they all run default ISP-provided WiFi, probably 2.4 Ghz no less, and so on.  We'd encounter random but frequent choppiness with video, occasionally the audio too, and it seems to be two-way where for example one day my caller will say I've frozen up or am choppy, and other days I see they freeze up, or get the iOS "Poor Connection" message in Facetime, etc.  

 

This occurs on any Apple device in this house, so I believe 3 phones and at least an iPad.  All are on the 5Ghz band and showing great dbm etc.  Internet speeds are fast all around, no jitter, no latency above 15ms, all is good.  

 

But I'm also running a separate network of Cisco RV345's and WAP571's - and finally after months of wondering what the problem with everyone else's WiFi is, I decided hey what the hell I'll join to my WAP571's and see how Facetime goes.  Flawless.  Consistently flawless.  

 

So, it's pretty clear to me that the Meraki devices are the issue - problem is, I'm not really using much in the way of customized config.  No Lay 7 firewall polices are set at all - I think I may have some basic stuff like ICMP ping blocked or what not, but absolutely no pollicies preventing mobile devices from doing video properly.  So, is there an actual iPhone-friendly setup I SHOULD be doing?  Or what, is the MX's firewall and the MR's firewall combined perhaps causing too much drag on the streaming?  

 

I'd call support but thought I'd start here.  Thank you.  

6 REPLIES 6
Highlighted
Head in the Cloud

Re: Apple FaceTime poor connection

Interesting.  I have had full stack Meraki at my home for a few years as well.  I use a lot of Apple devices and never noticed any particular issue with FaceTime although I only use it a couple times a month for calls under <15 minutes.

 

I am aware of an issue with 802.11k on v26 MR firmware that causes the RingCentral voip app to drop packets for ~5-10 seconds every 5-10 minutes.  I have been able to work around this particular issue by having Meraki support disable 802.11k on v26 for me.  It is also a workaround to stay on v25.  Meraki support points to a problem Apple needs to resolve.  Here is link to that discussion: https://community.meraki.com/t5/Wireless-LAN/RingCentral-Application-Disconnecting-Mobile-Devices/td...

 

 

Highlighted
Here to help

Re: Apple FaceTime poor connection

Out of interest is the cisco WiFi also 5GHz, have you tried forcing the Meraki to only broadcast 2.4GHz and see if it is any better? Also I assume you have used a channel scanning piece of software to see if there is anything using the same channels that might possibly interrupt your connection (grasping at straws I know)?

Highlighted
Here to help

Re: Apple FaceTime poor connection

Hello to you both, thanks for the replies.  I was half-done a reply on another ocmputer then lost track of where the darn thing was (a few physical machines, several Win 10 virtual desktoips each, and a partridge in a pear tree) so I'll start again.  

 

I don't even touch 2.4 Ghz where I can help it, so it's 5 Ghz only so far.  I'll try 2.4 for testing though - any kind of differential diag is a good thing. 

 

The dbm ratings are very good for the devices if I view them via the device-specific info screens in the Meraki dashboard, so I'm hoping that means there's no channel interference since the ratings (I think) are meant as an aggregate index of performance and not just a measure of signal to noise ratio stuff.  That said, you'd be incorrect to assume I checked, since actually I'm a bit of a dummy when it comes to WiFi spectrum surveying - I've never had to do it since so far the solution for most clients' awful WiFi has just been to move to 5Ghz.  🙂 So I'm open to any input on that in terms of what tools you'd suggest.  I'm not keen to use Linux tools though, Linux being for the smart folk out there and I'm just a Windows guy.  

 

This forum display only shows your post so I can't see the other gentleman's post to reply to it so I'll click Post here and reply again momentarily.  

Highlighted
Here to help

Re: Apple FaceTime poor connection

Thanks for letting me know about the RingCentral thing.  I don't have that myself but one of my clients does - he hasn't reported issues but if I hear about it I'll have some idea where to start.  I'll take a look at the article you linked for any parallel issue stuff.  There's also some Apple iOS updates to get done on my end so I"ll try that too.  Phil suggested testing on 2.4GHz - I'll try that too.  

But ultimately it seems that the Meraki platform doesn't need any special stuff like a custom WMM policy or what not, to make Facetime work.  I should also try some other kind of vidoe conference.  

FWIW, streaming video never has issues, so it's so far only Facetime and the actual Internet connection is always strong.  Anyway, when I can I will jump into this testing and report back (even if it takes a couple weeks).  

Highlighted
New here

Re: Apple FaceTime poor connection

Ever find a resolution for this. I have the same exact problem and haven't been able to pin point it other than its specific to Meraki. When I switch over to an ASUS router/AP, no issues.

Highlighted
Here to help

Re: Apple FaceTime poor connection

I actually left this alone for a while, and then forgot about it to boot.  The problem didn't seem "as bad" as it had been, but still definitely a Meraki-specific problem because as soon as I switch over to my network running some Cisco WAP571's connected to an RV345P I have no problems.  

 

I tend to be too busy these days to focus time on things that aren't driving me crazy, so my ability to switch to a different network when doing FaceTime gives me a workaround for now.  But as soon as it flares up, or a customer of mine needs this fixed, I'll be back to this issue like it had to be solved yesterday.  Were you able to do any kind of troubleshooting via the stuff in this thread?  Like anything tried that wasn't discussed here?  

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.